mozilla hangs (many flash examples)

VERIFIED DUPLICATE of bug 132759

Status

()

Core
Plug-ins
P3
critical
VERIFIED DUPLICATE of bug 132759
17 years ago
16 years ago

People

(Reporter: rogert, Assigned: rubydoo123)

Tracking

({hang})

Trunk
mozilla1.2alpha
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

18.34 KB, application/x-shockwave-flash
Details
(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011221
BuildID:    2001122108

c

Reproducible: Always
Steps to Reproduce:
1.open this url
2.
3.

Comment 1

17 years ago
Worksforme. Linux 0.9.7 (2001122108)

Comment 2

17 years ago
Hang with 0.9.7/Linux, with 100% CPU time. 

WFM with 2002010708/Linux. Moz is using cca 30% CPU time on 660 MHz PIII.

Reporter, can you try with a more recent build (nightly) ?

Updated

17 years ago
Keywords: hang

Comment 3

17 years ago
I have been seeing hangs when going to a page with flash.  More specifically,
when I go to a page with flash and then open a link in a new window from that
page which also happens to contain flash, Mozilla just sits there taking up
between 80% and 90% CPU and won't let me switch back to the other window.  I
also cannot close the most recent window that was opened.  I end up having to
kill Mozilla.  This is using the last few days of builds of Mozilla on Win2k (SP2).

I'll try to come up with an exact way to reproduce this...

Jake

Comment 4

17 years ago
Ok, forget the more complex stuff of openening one flash page and then opening 
another one in a new window.  Here is a much simpler way to reproduce this:

1.  go to:  http://www.bluescreenofdeth.net/
2.  try to move mozilla around, or use the menus, or open a new window (ctrl+n)

In fact, the only things that you can really do are get the focus into the url 
bar and be able to type there, and use the mouse wheel to scroll.  I actually 
did get the scrollbar to work by dragging it after clicking around a bit.  That 
is about all the functionality you will find.  

Mozilla, in this case, is only using between 30% and 65% CPU, but there appear 
to be serious focus issues where many parts of mozilla cannot be focused and 
key shortcuts (like ctrl+n) don't have any effect.

I did find a workaround...at least to get out of the hang.  Get the focus into 
the url bar, type some stuff (doesn't matter what), hit <enter>.  Now you will 
be at some file-not-found page.  Now all browser windows are functional again.  
Make sure you click a toolbar shortcut to go to another site or the sites file-
not-found page might re-direct you right back to the page that causes the 
freeze.

This is really bad because (other than using the workaround) if I have a bunch 
of windows open when doing some research and I happen upon a page with flash, 
all the windows cease to be usable and I have to scrap all the stuff I was 
currently doing and kill Mozilla.

I'm confirming this.

Jake
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
Component: Browser-General → Plug-ins
OS: Linux → All

Comment 5

17 years ago
Ak!  Didn't realize that this was reported as "browser-general".  Changed 
component to "Plugins" and changed OS to "All" since it is happening on both 
Linux and Windows 2000.

This really needs to be looked at for 0.9.8.  There are lots of flash pages out 
there.  I don't even care for it much, but it does have its uses and lots of 
people have the plugin already.  Given this, when a flash animation freezes all 
open Mozilla browsers, I see that as a blocker to 0.9.8 release.  I won't 
change it to blocker myself, but I recommend the Plugins owner does.

jake

Comment 6

17 years ago
Yes, you can try http://news.sina.com.cn to comfirm it .
It is one of the most famous Chinese websites.
Too many flash Ad. eat up all cpu resource and hang moz.


Comment 7

17 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011230

Also http://www.locatel.fr/ locks up on both 0.9.6 and 0.9.7 after staying on
the site a few seconds.

Comment 8

17 years ago
I noticed that the http://www.locatel.fr/ flash page only started hanging when
they put on the nifty snowflake animations. Before that it didn't hang Mozilla.
It's completely impossible to do anything but kill Mozilla.

Comment 9

17 years ago
All of these examples WFM with current builds on both Mac OS X and Win2k.
Reassiging to plugin team for further triage.
Assignee: asa → beppe
QA Contact: doronr → shrir

Comment 10

17 years ago
I have just tested a bunch of examples (around 50) against NS 6.2.1 and release
0.9.9 on a Linux box and it looks like with 0.9.9 it has improved a lot. I
haven't been able to hang moz yet. The locatel.fr flash I pointed to above is
not the correct flash anymore though. The one that posed problems had lots of
snowflake animations on it which bogged down moz. I know I should have attached
the flash. Sorry. Anyway, from what I experience now it WFM too. Hang on. I just
found this one:

http://www.deviantart.com/deviation.php?id=130209
Flash->interactive - It's called recreational orbit.

I can add no more than around 5 balls before moz stops responding. This is on a
P2-450 mhz.

Comment 11

17 years ago
Created attachment 75555 [details]
Flash bogs down moz

Flash with balls.

Comment 12

17 years ago
cool flash example, on my w2k p4 1.5G, once I run it in IE5.5 and close IE I 
won't be able to restart IE without rebooting the machine.

Comment 13

17 years ago
That's strange.

I have some more test results for you.

1:
AMD 1.4g Win XP machine with IE 6. No problems at all. I can close IE and start
it again. I added more than 20 balls and no slowdown.

2:AMD Duron 800Mhz, 128 MB ram, running Windows 2000 *through* VMWare, IE
version 5.50.4807.2300. No problems at all. The flash ran slower but interface
was responsive and I could close IE and start it again. Added around 20 balls.

3:
P2-450Mhz, Opera 6 beta 1 for Linux. No problems again.

4:
AMD 1800+ 256 MB RAM, Linux, Moz 0.9.9. Adding less than 10 balls and interface
is completely unresponsive.
(Assignee)

Comment 14

16 years ago
assigning to serge and putting into 1.2 bucket
Priority: -- → P3
Target Milestone: --- → mozilla1.2alpha

Comment 15

16 years ago
is this , by any chance, related to bug 58339? I could not repro the hang on 
windows. reporter, can u pls check ?Thx!

Comment 16

16 years ago
(Using 0.9.9 on both Linux and Windows in the following).

I just tried it on a P3-500 Mhz with Debian stable/2.4.18 kernel. With audio
playing and not playing (XMMS 1.2.6) in the background the Flash plays nicely
but the interface is unresponsive as usual. I don't think it's related to 58339.

New info: I now noticed that if I leave the flash playing for a few seconds with
the cursor outside the flash area the interface gets responsive again. Not fully
100% lightning-fast-as-usual responsive but enough to navigate around. However,
as soon as I move the cursor inside the flash area its unresponsive again for
some seconds. The more balls I add the longer it takes before the interface gets
responsive once I move the cursor out of the flash area it seems.

I now also tried it on a AMD 1.4g Win XP machine and I would say it performed
acceptable there. Added around 70 balls and only a little unresponsiveness was
noticed which IE 6 also suffered from. Maybe its a *NIX only problem.

Comment 17

16 years ago
using Netscape 7.0 beta - http://www.kylie.com pegs the CPU at 100%. navigating
off of that page brings the cpu back down.
(Assignee)

Comment 18

16 years ago
We have been tracking FLash CPU usage issues in bug 132759, which I believe is
the same issue as reported in this bug. Although this was reported before that
one, bug 132759 has all of the tracking data in it already.

Marking as a dup of 132759
(Assignee)

Comment 19

16 years ago

*** This bug has been marked as a duplicate of 132759 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 20

16 years ago
big time dup, verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.