crash in js::detail::HashTable<T>::lookupForAdd(char const* const&)

RESOLVED DUPLICATE of bug 1132502

Status

()

--
critical
RESOLVED DUPLICATE of bug 1132502
3 years ago
3 years ago

People

(Reporter: aklotz, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-e2d28f14-f41d-495c-acd1-be88d2150731.
=============================================================
Reddit user /u/daveruiz is seeing this repeatedly and frequently.
https://www.reddit.com/r/firefox/comments/3fc1us/massive_number_of_crashes_are_driving_me_insane/
This looks like the same crash reported in bug 1180954.

It looks like heap corruption, which is going to be really hard to track down unfortunately.

Aaron, do you have steps to reproduce this?  Can you see if it still happens if you restart with extionsions disabled?

https://support.mozilla.org/en-US/kb/firefox-crashes-troubleshoot-prevent-and-get-help#w_check-to-see-if-the-crash-happens-in-safe-mode
Flags: needinfo?(aklotz)
(Reporter)

Comment 2

3 years ago
I'm reaching out to the Reddit user...
Flags: needinfo?(aklotz)

Updated

3 years ago
See Also: → bug 1180954

Updated

3 years ago
Crash Signature: [@ js::detail::HashTable<T>::lookupForAdd(char const* const&)] → [@ js::detail::HashTable<T>::lookupForAdd(char const* const&)] [@ js::detail::HashTable<T>::lookupForAdd]
This was almost certainly part of the heap corruption fiasco last month. Please reopen if this is still recuring.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1180954
(In reply to Terrence Cole [:terrence] from comment #4)
> This was almost certainly part of the heap corruption fiasco last month.
> Please reopen if this is still recuring.

Looking again, I'm pretty sure it's the same problem as bug 1132502.
Duplicate of bug: 1132502
You need to log in before you can comment on or make changes to this bug.