Closed Bug 1189976 Opened 4 years ago Closed 4 years ago

Rules and separators in Control Center panel are too dark

Categories

(Firefox :: Theme, defect, P1)

All
Windows 10
defect

Tracking

()

VERIFIED FIXED
Firefox 42
Iteration:
42.3 - Aug 10
Tracking Status
firefox41 --- verified
firefox42 --- verified

People

(Reporter: shorlander, Assigned: dao)

References

Details

(Keywords: regression, Whiteboard: [fxprivacy] [campaign][testday-20150901])

Attachments

(2 files, 1 obsolete file)

Attached image Separator Comparison
The rules and separators in the Control Center panel are too dark. They should match the rest of the panels.
Flags: firefox-backlog?
Regression of bug 1180200.
Blocks: 1180200
Keywords: regression
We seem to be using hsla(210,4%,10%,.14) in the menu panel, and then we override that to ThreeDLightShadow for non-default Windows themes but not for Linux although Linux themes are more diverse than non-default Windows themes. Pretty messy.
Flags: firefox-backlog? → firefox-backlog+
Priority: -- → P2
We may want to get bug 1146044 done to avoid code duplication.
Blocks: 1188565
Assignee: nobody → dao
Attached patch panel-separator-color.diff (obsolete) — Splinter Review
Attachment #8643555 - Flags: review?(ttaubert)
typo...
Attachment #8643555 - Attachment is obsolete: true
Attachment #8643555 - Flags: review?(ttaubert)
Attachment #8643558 - Flags: review?(ttaubert)
Attachment #8643558 - Flags: review?(ttaubert) → review+
Keywords: checkin-needed
Flags: qe-verify+
https://hg.mozilla.org/mozilla-central/rev/d2a22e5315dd
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
No longer blocks: 1188565
Iteration: --- → 42.3 - Aug 10
QA Contact: mwobensmith
Whiteboard: [fxprivacy] → [fxprivacy] [campaign]
Priority: P2 → P1
This issue is still reproducible on Ubuntu 12.04 on the latest Nightly FF 43 Build Id: 20150812030206 and FF 42 DevEdition Build Id:20150812004006. Should I log a new bug  just for Ubuntu or the same bug will be used for tracking?
Flags: needinfo?(dao)
The separator color on Ubuntu looks fine to me. We don't have much choice on Linux either since ThreeDLightShadow is mostly useless the way our gtk widget code implements it.
Flags: needinfo?(dao)
This is not fixed in FF 41b4 Win 7.
Works fine on 42.0a2 (2015-08-24).
Flags: needinfo?(dao)
(In reply to Paul Silaghi, QA [:pauly] from comment #12)
> This is not fixed in FF 41b4 Win 7.
> Works fine on 42.0a2 (2015-08-24).

Indeed! I pushed the wrong patch in bug 1180200.
Flags: needinfo?(dao)
This is verified fixed as part of a QA test day.
Status: RESOLVED → VERIFIED
Whiteboard: [fxprivacy] [campaign] → [fxprivacy] [campaign][testday-20150901]
You need to log in before you can comment on or make changes to this bug.