Windows 10 crash in CLockedList<T>::ForEachEntry(CLockedList<T>::CListWorker&)

RESOLVED WORKSFORME

Status

External Software Affecting Firefox
Flash (Adobe)
--
critical
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: philipp, Unassigned)

Tracking

({crash})

unspecified
All
Windows 10
crash

Firefox Tracking Flags

(firefox39 affected, firefox40 affected, firefox41 affected, firefox42 affected)

Details

(crash signature, URL)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-878757c9-15a4-46e8-b08b-ab87e2150729.
=============================================================

Crashing Thread
Frame 	Module 	Signature 	Source
0 	audioses.dll 	CLockedList<ATL::CComPtr<IAudioSessionEvents>, 0, 1>::ForEachEntry(CLockedList<ATL::CComPtr<IAudioSessionEvents>, 0, 1>::CListWorker&) 	
1 	audioses.dll 	CAudioSessionControl::OnAudioSessionEvent(MEDIA_NOTIFICATION_BLOCK*) 	
2 	audioses.dll 	CAudioSessionControl::CAudioSessionNotificationDelegator::OnMediaNotification(MEDIA_NOTIFICATION_BLOCK*) 	
3 	mmdevapi.dll 	CMediaNotifications::OnMediaNotificationWorkerHandler(_TP_CALLBACK_INSTANCE*) 	
4 	mmdevapi.dll 	CMediaNotifications::MediaNotificationWorkerHandler(_TP_CALLBACK_INSTANCE*, void*) 	
5 	ntdll.dll 	TppSimplepExecuteCallback 	
6 	ntdll.dll 	TppWorkerThread 	
7 	kernel32.dll 	BaseThreadInitThunk 	
8 	ntdll.dll 	__RtlUserThreadStart 	
9 	ntdll.dll 	_RtlUserThreadStart

this is one of the signatures which ranks high among incoming win10 crashes. the comments by affected users indicate that it's happening once they want to use their webcam (& that's a condition which started with the win10 update).
if the crash data contains affected urls, maybe it's possible to reprocude this?

Comment 1

3 years ago
These are all in Flash processes. Who should these reports go to?
Flags: needinfo?(benjamin)

Comment 2

3 years ago
Adalucinet, is this something you can include in Windows 10 testing?  I'm not sure I want to be sending anybody to the cesspool that is chatroulette, but there have got to be other sites or even Flash demos that use the webcam that we can test with.

It's interesting to me that the crash is entirely in the Windows code. It looks like it's in an audio codepath, not video, so perhaps just a Flash audio chat site would work to reproduce.
Component: Plug-ins → Flash (Adobe)
Flags: needinfo?(benjamin) → needinfo?(alexandra.lucinet)
Product: Core → Plugins

Comment 3

3 years ago
FWIW, this one works and doesn't require strategically placed post-it notes: 
http://www.trust.com/en/support/troubleshooting/webcam

Updated

3 years ago
Duplicate of this bug: 1189351

Comment 5

3 years ago
From https://bugzilla.mozilla.org/show_bug.cgi?id=1189351#c0 :

> Steps to reproduce:
> 
> Started a webcam session here https://tinychat.com/peopleinside and when i
> select Webcam and mic Flash Crash
> 
> 
> Actual results:
> 
> when i select Webcam and mic Flash Crash
> 
> 
> Expected results:
> 
> Not crash
(Reporter)

Comment 6

3 years ago
i'm able to reproduce on http://www.flabell.com/flash/Audio-Recorder-for-Adobe-Flash-350 by hitting the record button and allowing mic access - no chat roulette or sticky notes required :-)
(Reporter)

Comment 7

3 years ago
these were different signatures i got as well: 
@ mozalloc_abort(char const* const): https://crash-stats.mozilla.com/report/index/8e592612-2f58-4c18-a635-0d05b2150803
@ @0x0 | CAudioSessionControl::OnAudioSessionEvent(MEDIA_NOTIFICATION_BLOCK*): https://crash-stats.mozilla.com/report/index/c17c7043-a201-4425-a4a3-4ccb32150803

Comment 8

3 years ago
This is ADBE 4030516
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #2)
> Adalucinet, is this something you can include in Windows 10 testing?  I'm
> not sure I want to be sending anybody to the cesspool that is chatroulette,
> but there have got to be other sites or even Flash demos that use the webcam
> that we can test with.
We'll include this particular test case in our smoke suite, using the sample from Comment 6 for now.

> It's interesting to me that the crash is entirely in the Windows code. It
> looks like it's in an audio codepath, not video, so perhaps just a Flash
> audio chat site would work to reproduce.
I've managed to reproduce the crash easily on:
* Firefox 39.0 (20150630154324) [1]
* Firefox 40.0 (20150803103853) [2]
* Firefox 40.0b9 (20150730171029) [3]
* Firefox 41.0a2 (2015-08-04) [4]
* Firefox 42.0a1 (2015-08-03) [5]
using the testcase from Comment 6 with Windows 10 x64 (10240) and Flash 18.0.0.209. Here's a memory report as well: https://www.dropbox.com/s/sv24w54c446fxo1/memory-report.json?dl=0.

[1] https://crash-stats.mozilla.com/report/index/42fc218c-7596-402d-96cb-9e5432150804
[2] https://crash-stats.mozilla.com/report/index/e8256306-f209-4932-aee6-d662e2150804
[3] https://crash-stats.mozilla.com/report/index/7f976c9c-d32b-4eeb-9701-90c382150804
[4] https://crash-stats.mozilla.com/report/index/ba18e81a-1b49-4c4a-9e03-3f7f32150804
[5] https://crash-stats.mozilla.com/report/index/27d391fe-bf80-4055-8cb3-e558a2150804
status-firefox39: --- → affected
status-firefox40: --- → affected
status-firefox41: --- → affected
status-firefox42: --- → affected
Flags: needinfo?(alexandra.lucinet)
Hardware: x86 → All
(Reporter)

Updated

3 years ago
Crash Signature: [@ CLockedList<T>::ForEachEntry(CLockedList<T>::CListWorker&)] → [@ CLockedList<T>::ForEachEntry(CLockedList<T>::CListWorker&)] [@ @0x0 | CAudioSessionControl::OnAudioSessionEvent(MEDIA_NOTIFICATION_BLOCK*)]

Comment 10

3 years ago
Hi,
Also Firefox ESR 38.1.0 is affected.

Comment 11

3 years ago
Firefox 39.0.3 affected
(Reporter)

Comment 13

3 years ago
i'm no longer able to reproduce it on the test site from comment #6 with flash updated to 18.0.0.232, but according to the crash stats it still seems to continue on other pages...

Comment 14

3 years ago
YES still present!
(Reporter)

Comment 15

2 years ago
this id doesn't seem to be accessible through the public adobe bugbase. 

the plugin crash is still happening with the latest flash beta build as far as i'm aware: https://crash-stats.mozilla.com/report/index/5bdf9a56-fef3-404b-8e4e-a22042150824
Flags: needinfo?(jeclark)

Comment 16

2 years ago
We believe that this issue is fixed in Flash Player 19.0.0.159 and higher, which should be available at http://www.adobe.com/go/flashplayerbeta in the next beta drop.  That fix hasn't landed in the beta yet, but should be included in this week's beta drop, which I'm guessing will post tomorrow.
Flags: needinfo?(jeclark)
(Reporter)

Comment 17

2 years ago
thank you for the update!

Updated

2 years ago
Duplicate of this bug: 1200001

Comment 19

2 years ago
This seems resolved in Flash Player 19 who be released soon.
https://forums.adobe.com/message/7931464#7931464

Comment 20

2 years ago
Sorry, also in Flash Player 19 issue are present on Firefox. Flash didn't crash but audio not works. Is no possible record audio from microphone.. so issue still present and need urgent fix.

Comment 21

2 years ago
Is not fixed also 19 ... yes not crash but audio recording not works

Updated

2 years ago
Flags: needinfo?(jeclark)

Comment 22

2 years ago
This bug is specific to the crash, which is what we fixed.  While the recording issue is something that we'd be happy to look at, it doesn't looks like it had the same root-cause.  It would be much better to file a new bug to track that issue.  Feel free to CC me and I'll get something going on the Adobe side.

Comment 23

2 years ago
Ok thanks. For me is the same problem as I see Flash audio goes in tilt on 18 and also in 19 but ok, created new topic https://bugzilla.mozilla.org/show_bug.cgi?id=1206278
Flags: needinfo?(jeclark)
(Reporter)

Comment 24

2 years ago
based on comment #16 and since the signature isn't showing up any longer with recent flash player builds in crash stats (including version 19.0.0.185, that got publicly released yesterday) i'm marking this bug as resolved.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.