Closed Bug 1190180 Opened 4 years ago Closed 4 years ago

Need to install the GTK3 runtime on automation VM

Categories

(Release Engineering :: General, defect, critical)

defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1190317

People

(Reporter: julienw, Unassigned)

References

Details

Since the switch to GTK3 we need GTK3 on the machines that run Gaia unit tests with B2G Desktop.

See the following error:

XPCOMGlueLoad error for file /home/tester/git_checkout/b2g/libmozgtk.so:
libgtk-3.so.0: cannot open shared object file: No such file or directory
Couldn't load XPCOM.


From https://s3-us-west-2.amazonaws.com/taskcluster-public-artifacts/h1dtMu9PRNacSNkGu2PzfA/2/public/unit_tests_b2g/debug.log

It seems it does not happen on all machines. Maybe it does not happen for the builds that are not on taskcluster yet because I don't see the issue on gecko builds.
Blocks: gtk3
Blocks: 1186748
Ryan, Tomcat, I feel we need to close the gaia tree because of this, what do you think ?
Flags: needinfo?(ryanvm)
Flags: needinfo?(cbook)
Is this the root cause (from a few lines above)?

/bin/bash: /home/tester/git_checkout/b2g_sdk/39.0a1-2015-03-05-16-02-02/b2g/xpcshell: No such file or directory
Tracking down the problem...

From: https://queue.taskcluster.net/v1/task/h1dtMu9PRNacSNkGu2PzfA

The image used is:

"image": "taskcluster/gaia-taskenv:0.8.11"

The command run is:

    "command": [
      "entrypoint",
      "mkdir -p artifacts && ./bin/ci run unit-tests-in-b2g 2> artifacts/debug.log"
    ],
The last working one I see is:

https://queue.taskcluster.net/v1/task/BVgdAKrxR3C9yiXDIHbIVQ

This was using:

    "image": "taskcluster/gaia-taskenv:0.8.11",

    "command": [
      "entrypoint",
      "mkdir -p artifacts && ./bin/ci run unit-tests-in-b2g 2> artifacts/debug.log"
    ],

So there is no change to the image used, or the command ... so the problem must lie elsewhere. Investigating...
I'm going to rerun the last working build (from comment 4), to see if it also now breaks, or is still ok...
Strange, it failed now, but for a different reason:

https://s3-us-west-2.amazonaws.com/taskcluster-public-artifacts/ItqUdQuCSLqhd2qEAQ2RQA/0/public/logs/live_backing.log

Listening on port: 8789
Loading config file '/home/tester/git_checkout/build/config/test-agent-server.js'
Waiting for server on port 8080 failed.
No, it's likely the same reason, you're not looking at the same log file.
gaia is closed now
Flags: needinfo?(cbook)
Flags: needinfo?(ryanvm)
Depends on: 1190317
Gaia closed again at Julien's request.
We tried to backout some patches in bug 1186748 but I still see the issue in [1]. From the task inspector [2] I see that we're using a build that has the backout (hg hash is 1d4f44ee51668865945db95c5fbd898e71955a33). so :/

[1] https://s3-us-west-2.amazonaws.com/taskcluster-public-artifacts/2TKefmTMQ_S7P5zn3CvSfw/0/public/unit_tests_b2g/debug.log
[2]https://tools.taskcluster.net/task-inspector/#Z5XUTERCSyqHpPsu78DiTg/
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1190317
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.