Closed Bug 1190276 Opened 5 years ago Closed 5 years ago

[Messages] In a "new" activity we don't keep the body if the phone number has a conversation already

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: julienw, Assigned: julienw)

Details

(Whiteboard: [sms-sprint-FxOS-S4])

Attachments

(2 files)

STR:
1. Use a 'new' activity with both body and phone number; the phone number must belong to an existing conversation.

Expected:
* We should be redirected to the correct conversation.
* The composer should be prefilled.

Actual:
* We're redirected to the correct conversation but the composer stays empty.

(attachment to reproduce to come)
Attached file test-activity-new.html
Whiteboard: [sms-FxOS-S4]
Comment on attachment 8642345 [details] [review]
[gaia] julienw:1190276-body-and-number-activity > mozilla-b2g:master

Hey Oleg,

here is a small patch to fix this simple issue I found while working on bug 1162030.

As I explained last week, I chose to move to the Composer instead of the Conversation in case we had both a recipient and a body, even if the recipient has an existing conversation. The reason is that if the conversation has a draft, I couldn't think of a right behavior in this case.
Attachment #8642345 - Flags: review?(azasypkin)
Whiteboard: [sms-FxOS-S4] → [sms-sprint-FxOS-S4]
Comment on attachment 8642345 [details] [review]
[gaia] julienw:1190276-body-and-number-activity > mozilla-b2g:master

Looks good! Just few minor nits and question about unit test at github.

Thanks!
Attachment #8642345 - Flags: review?(azasypkin) → review+
fixed nits and landed
master: 9ac577619f17877c3831c960d7ec0b5524497b30
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.