Closed Bug 1190346 Opened 9 years ago Closed 8 years ago

about:support displays nothing if an add-on has an empty name

Categories

(Toolkit :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1264725
Tracking Status
firefox42 --- affected

People

(Reporter: florian, Unassigned)

References

Details

Attachments

(1 file)

Attached image about-addons.png
I recently cleaned up a machine that had lots of malware installed. I tried to use about:support to get information about what had been done to Firefox, but the page was completely empty.

There was a warning in the error console:
1438441191258	addons.manager	WARN	Exception calling callback: TypeError: a.name is null (resource://gre/modules/Troubleshoot.jsm:209:12) JS Stack trace: extensions/</<@Troubleshoot.jsm:209:13 < extensions/<@Troubleshoot.jsm:206:7 < safeCall@AddonManager.jsm:173:5 < getAddonsByTypes_noMoreObjects@AddonManager.jsm:2239:9 < AOC_callNext@AddonManager.jsm:305:7 < getAddonsByTypes_concatAddons@AddonManager.jsm:2234:11 < SocialAddonProvider.getAddonsByTypes@SocialService.jsm:1027:7 < callProviderAsync@AddonManager.jsm:235:12 < getAddonsByTypes_nextObject@AddonManager.jsm:2229:1 < AOC_callNext@AddonManager.jsm:311:7 < getAddonsByTypes_concatAddons@AddonManager.jsm:2234:11 < PL_getAddonsByTypes@PluginProvider.jsm:139:7 < callProviderAsync@AddonManager.jsm:235:12 < getAddonsByTypes_nextObject@AddonManager.jsm:2229:1 < AOC_callNext@AddonManager.jsm:311:7 < getAddonsByTypes_concatAddons@AddonManager.jsm:2234:11 < GMPProvider.getAddonsByTypes@GMPProvider.jsm:592:7 < callProviderAsync@AddonManager.jsm:235:12 < getAddonsByTypes_nextObject@AddonManager.jsm:2229:1 < AOC_callNext@AddonManager.jsm:311:7 < getAddonsByTypes_concatAddons@AddonManager.jsm:2234:11 < LightweightThemeManager_getAddonsByTypes@LightweightThemeManager.jsm:446:7 < callProviderAsync@AddonManager.jsm:235:12 < getAddonsByTypes_nextObject@AddonManager.jsm:2229:1 < AOC_callNext@AddonManager.jsm:311:7 < getAddonsByTypes_concatAddons@AddonManager.jsm:2234:11 < getAddonsByTypes_getVisibleAddons@XPIProvider.jsm:3838:7 < makeSafe/<@XPIProviderUtils.js:145:17 < asyncMap_gotValue@XPIProviderUtils.js:180:7 < asyncMap_callback@XPIProviderUtils.js:187:9 < completeAddon@XPIProviderUtils.js:134:5 < getAddon@AddonRepository.jsm:580:7 < this.AddonRepository.getCachedAddonByID<@AddonRepository.jsm:592:5

The JS exception seems to be on this line:
        let lc = a.name.localeCompare(b.name);
http://hg.mozilla.org/mozilla-central/annotate/3cd0d76851a3/toolkit/modules/Troubleshoot.jsm#l222

This is caused by a (randomly generated) add-on dropped into the user's profile. Here is the install.rdf file of that add-on:
<?xml version="1.0"?>
<RDF xmlns="http://www.w3.org/1999/02/22-rdf-syntax-ns#" xmlns:em="http://www.mozilla.org/2004/em-rdf#">
<Description about="urn:mozilla:install-manifest">
<em:id>ru_pza_kyjkv@gvcrlyjfyndhzejxlz.edu</em:id>
<em:name></em:name>
<em:version>4.11</em:version>
<em:description></em:description>
<em:bootstrap>false</em:bootstrap>
<em:targetApplication>
<Description>
<em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id>
<em:minVersion>2.0</em:minVersion>
<em:maxVersion>100</em:maxVersion>
</Description>
</em:targetApplication>
</Description>
</RDF>

Note the <em:name></em:name> line, where the name is empty.

I'm not sure it makes sense for us to accept to install add-ons without name (Dave, do you know if this was an intentional behavior of the add-on manager?), but the add-on manager shows the add-on's name as 'null' (see attached screenshot), so the about:support page should probably do the same thing for consistency, or do something more explicit, or in any case, should not break.
Flags: needinfo?(dtownsend)
No, name is meant to be a required property of an add-on, we should really be rejecting any add-ons with no name
Flags: needinfo?(dtownsend)
This was fixed in about:support in bug 1264725, afaict.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: