We have a proliferation of `profile.getAccount() == nil` checks throughout our codebase. I'd like to add two things: hasAccount -> Bool hasSyncableAccount -> Bool The latter is a subset, and implies that no action is needed to make the account usable.
Comment on attachment 8642611 [details] [review] Pull req. bnicholson reviewed on IRC. https://github.com/mozilla/firefox-ios/commit/2cfdd93ce338bd2592230446778eaffacd47ce7c
Attachment #8642611 - Flags: review? → review+
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.