Test failure with exception

VERIFIED DUPLICATE of bug 1175116

Status

VERIFIED DUPLICATE of bug 1175116
3 years ago
9 months ago

People

(Reporter: hub, Unassigned)

Tracking

Details

(Reporter)

Description

3 years ago
When running marionette tests (gaia integration tests), if an exception occur and it is not caught by the test() function, then it cause a test failure, with an obscure error of "Crash detected but error running stackwalk"

Instead the exception should be caught by the top level and reported as such along with the failure.

Exception like "ElementNotFound" from the Marionette client.
Filed bug 1199002 about catching and propagating errors from injected scripts to the local end.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1175116
(Reporter)

Updated

3 years ago
Status: RESOLVED → VERIFIED

Updated

9 months ago
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.