Can't drag a tab to create a new window

RESOLVED DUPLICATE of bug 863512

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 863512
2 years ago
2 years ago

People

(Reporter: mbest, Unassigned)

Tracking

42 Branch
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(firefox42 affected)

Details

(Reporter)

Description

2 years ago
In windows 10, I try and drag a tab to create a new window on a second monitor.  I am unable to detach the tab, it just slides along the window header.  A work around is to select "launch in new window".
(Reporter)

Comment 1

2 years ago
Turns out the drag does create a new window.  There is no graphic attached to the mouse cursor to indicate that the tab is being dragged.
Hey Martin,

I suspect this may have been bug 863512, which only affected e10s.

I see you filed this on Firefox 42, and the fix landed on Firefox 43. Can you confirm that things work properly for you if you disable e10s on Firefox 42? And also if you have e10s enabled on Firefox 43?
Flags: needinfo?(mbest)
(Reporter)

Comment 3

2 years ago
I have run some additional tests.  Looks like things work better in FF43, 32 bit on windows 10.  When I drag the tab, I do get a new window, I get small image of the window that is being dragged.  It however is not centered on the cursor.  It's down and to the right about half the screen width.  It does track with the mouse, just not positioned correctly relative to the cursor.
Flags: needinfo?(mbest)
(In reply to Martin Best (:mbest) from comment #3)
> I have run some additional tests.  Looks like things work better in FF43, 32
> bit on windows 10.  When I drag the tab, I do get a new window, I get small
> image of the window that is being dragged.  It however is not centered on
> the cursor.  It's down and to the right about half the screen width.  It
> does track with the mouse, just not positioned correctly relative to the
> cursor.

Okay, the bad alignment is bug 1202176, which should land soon.

Duping this to bug 863512.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 863512
(Reporter)

Comment 5

2 years ago
Just tested in Dev edition which is 42.2a.  Without e10s on, everything looks great.  Very nice fade effect on the window being dragged and the positioning relative to the cursor is current.
You need to log in before you can comment on or make changes to this bug.