Closed Bug 1191022 Opened 4 years ago Closed 4 years ago

Switching to and from reader mode should not trigger a visible reload

Categories

(Toolkit :: Reader Mode, defect, P4)

40 Branch
Unspecified
All
defect

Tracking

()

RESOLVED DUPLICATE of bug 1126967

People

(Reporter: phlsa, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [qx:spec])

When switching into reader mode (or out of reader mode) today, the tab title briefly flickers and the reload button briefly turns into a stop button.

This makes the transition feel janky and unpolished.
There should be no visible changes other than the ones in the viewport (ideally in both directions, but fixing the one going into reader view has priority)
Philipp, can you clarify the relation (or lack thereof) with bug 1126967?
Component: General → Reader Mode
Flags: needinfo?(philipp)
Product: Firefox → Toolkit
Ah, it seems that both cases are already captured in other bugs:
bug 1126967 - fix the flicker in the tab title when getting _into_ reader mode
bug 1184950 - fix the undesired reload when getting _out_ of reader mode

So I guess we should make both those bugs block the QX meta bug.
Or we transform this one into a meta bug for those two bugs...
Flags: needinfo?(philipp)
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1126967
You need to log in before you can comment on or make changes to this bug.