Closed Bug 1191178 Opened 4 years ago Closed 4 years ago

Add PerformanceRenderTiming and PerformanceCompositeTiming webidl

Categories

(Core :: DOM: Core & HTML, defect)

Other Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla43
Tracking Status
firefox43 --- fixed

People

(Reporter: hiro, Assigned: hiro)

References

(Blocks 1 open bug, )

Details

(Keywords: dev-doc-complete)

Attachments

(5 files, 3 obsolete files)

This bug is split from bug 1158032.

I am going to use this bug to just add webidl files and their implementations.
This bug is not affected by PerformanceObserver implementation so incoming patches can be reviewed.
Attachment #8643473 - Flags: review?(bugs)
Summary: Add PerformanceRnderTiming and PerformanceCompositeTiming webidl and → Add PerformanceRnderTiming and PerformanceCompositeTiming webidl
Summary: Add PerformanceRnderTiming and PerformanceCompositeTiming webidl → Add PerformanceRenderTiming and PerformanceCompositeTiming webidl
Attachment #8643473 - Flags: review?(bugs) → review+
Attachment #8643474 - Flags: review?(bugs) → review+
Filed also https://github.com/w3c/frame-timing/issues/46, but since that is sort of an enhancement only, or simplification, that doesn't need to block this bug.
Attachment #8643475 - Flags: review?(bugs) → review+
Unfortunately there is another unified build failure has been introduced by a patch for bug 992096 before checked-in.

This is a quick fix for the failure. I think GetSriLog() will move in one place though.
Attachment #8649551 - Flags: review?(francois)
Comment on attachment 8649551 [details] [diff] [review]
Part 0.1: Fix unified build failure caused by a patch for bug 992096

Review of attachment 8649551 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks Hiroyuki!
Attachment #8649551 - Flags: review?(francois) → review+
Rebased to master.
Attachment #8643474 - Attachment is obsolete: true
Attachment #8649738 - Flags: review+
Thank you, Olli! And thank you, François!

https://treeherder.mozilla.org/#/jobs?repo=try&revision=990b786f34e4
Keywords: checkin-needed
Another unified build error is caused by another commit. I am not sure which one is exactly.

Nicholas, can you please take a look this?

And part 0 patch is also rotted by this change. https://hg.mozilla.org/mozilla-central/diff/3413e043886c/dom/base/StructuredCloneHelper.cpp
I will update a new rebased patch for part 0 soon.
Flags: needinfo?(hiikezoe)
Attachment #8650215 - Flags: review?(n.nethercote)
Attachment #8650215 - Attachment description: Bug 1191178 - Part 0.2: Include nsBaseHashTable in nsScriptNameSpaceManager.h explicitly to avoid unified build errors. → Part 0.2: Include nsBaseHashTable in nsScriptNameSpaceManager.h explicitly to avoid unified build errors.
Rebased master, just dropped the change for StructuredCloneHelper.cpp.
Attachment #8643473 - Attachment is obsolete: true
Attachment #8650216 - Flags: review+
Comment on attachment 8650215 [details] [diff] [review]
Part 0.2: Include nsBaseHashTable in nsScriptNameSpaceManager.h explicitly to avoid unified build errors.

Review of attachment 8650215 [details] [diff] [review]:
-----------------------------------------------------------------

nsScriptNameSpaceManager.h doesn't use anything from nsBaseHashtable.h, or at least not that I can see.

Can you copy and paste the compiler error you're getting without this change? I suspect there might be a better way of fixing it. Thanks.
Attachment #8650215 - Flags: review?(n.nethercote) → review-
(In reply to Nicholas Nethercote [:njn] from comment #15)

> Can you copy and paste the compiler error you're getting without this
> change? I suspect there might be a better way of fixing it. Thanks.

Here it is:

/home/zoe/mozilla-central/dom/base/nsScriptNameSpaceManager.h:182:11: error: unknown type name 'PLDHashOperator'
  typedef PLDHashOperator

Thank you,
Flags: needinfo?(n.nethercote)
Comment on attachment 8650215 [details] [diff] [review]
Part 0.2: Include nsBaseHashTable in nsScriptNameSpaceManager.h explicitly to avoid unified build errors.

Review of attachment 8650215 [details] [diff] [review]:
-----------------------------------------------------------------

My mistake; this is right way to do it. Thank you for the extra information.
Attachment #8650215 - Flags: review- → review+
np, thanks for quick reviewing!
Flags: needinfo?(n.nethercote)
Unfortunately part 2 has been also rotted.

I pushed try now.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=27c8e27d265f
Attachment #8643475 - Attachment is obsolete: true
Attachment #8650231 - Flags: review+
Try result looks good.
Keywords: checkin-needed
Comment on attachment 8649738 [details] [diff] [review]
Part 1: Add a function to check frame timing preference value v2

>+  Preferences::AddBoolVarCache(&sIsFrameTimingPrefEnabled,
>+                               "dom.enable_frame_timing", true);
>+

Sorry, I didn't notice this. We should default to false here.
Depends on: 1199283
Nothing to document here anymore as this has been removed in bug 1271846.
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.