Closed Bug 1191223 Opened 6 years ago Closed 6 years ago

[AriesKK][Contacts]The screen will be black, and a gray area across the screen if you add a picture taken by camera in Contacts.

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master affected)

RESOLVED DUPLICATE of bug 1188286
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: huxiaoyan, Unassigned)

Details

(Keywords: regression, Whiteboard: [2.5-aries-test-run-1])

Attachments

(2 files)

[1.Description]:
[AriesKK][v2.5][Contacts]The screen will be black, and a gray  area across the screen if you add a picture taken by camera in Contacts.
Found time: 10:30
See attachment: logcat_1030.txt & Aries_2.5(kk).3gp

[2.Testing Steps]: 
1.Launch Contacts->Creat a new contact.
2.Tap the add picture icon and choose camera.
3.Take a picture and observe the screen carefully.

[3.Expected Result]: 
4.The screen will not be black, and a gray  area should not exist on screen.

[4.Actual Result]: 
4.The screen will be black, and a gray  area across the screen.

[5.Reproduction build]: 
Device: Aries KK 2.5(Affected)
Build ID               20150803195455
Gaia Revision          dbacf8364f4505d021b7d8fb9cabea325004dbcc
Gaia Date              2015-08-03 16:38:49
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/abc56d57f6e1
Gecko Version          42.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150803.191800
Firmware Date          Mon Aug  3 19:18:08 UTC 2015
Bootloader             s1

Flame KK 2.2: (Unaffected)
Build ID               20150804032504
Gaia Revision          f8b119ac30e97df991c97682ac4d4f9ca22e1793
Gaia Date              2015-07-31 13:20:55
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0c7a85251e10
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150804.065331
Firmware Date          Tue Aug  4 06:53:43 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Flame KK 2.5: (Unaffected)
Build ID               20150804150207

Gaia Revision          c5425d9f1f5184731a59ed4bc99295acbde30390

Gaia Date              2015-08-04 16:09:19

Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f3b757156f69

Gecko Version          42.0a1

Device Name            flame
Firmware(Release)      4.4.2

Firmware(Incremental)  eng.cltbld.20150804.184538

Firmware Date          Tue Aug  4 18:45:50 EDT 2015
Firmware Version       v18D v
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Cannot reproduce in aries with foxfooding build.
(In reply to Francisco Jordano [:arcturus] [:francisco] from comment #2)
> Cannot reproduce in aries with foxfooding build.

The foxfooding build is normally at 20150727151800. That would explain why you currently don't repro.

[Blocking Requested - why for this release]: Visual regression on a happy path.

No-Jun, are you aware of a landing that could cause this kind of regression?
blocking-b2g: --- → 2.5?
Component: Gaia::Contacts → Gaia::Camera
Flags: needinfo?(npark)
This sort of remind me of the bug 1189649, but not too sure. Kats, do you think those bugs are caused by graphics component by any chance?
Flags: needinfo?(npark) → needinfo?(bugmail.mozilla)
(In reply to No-Jun Park [:njpark] from comment #4)
> This sort of remind me of the bug 1189649, but not too sure. Kats, do you
> think those bugs are caused by graphics component by any chance?

It's possible but I would just be guessing. I haven't looked at bug 1189649 before this so I'm not sure if the root cause for that one could also result in this bug. I think it would be a quick first step to see if the regression window for that bug also applies to this bug; if it does then they are likely the same issue.
Flags: needinfo?(bugmail.mozilla)
2.5+ becuase of poor user experience
blocking-b2g: 2.5? → 2.5+
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1181290
Issue reported is similar to bug 1188286. Updating resolved duplicate to Bug 1188286
Duplicate of bug: 1188286
You need to log in before you can comment on or make changes to this bug.