Closed Bug 1191689 Opened 4 years ago Closed 4 years ago

crash in XPCWrappedNativeScope::MarkAllWrappedNativesAndProtos()

Categories

(Firefox :: General, defect, critical)

Unspecified
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1191465
Tracking Status
firefox42 --- affected

People

(Reporter: chiorean.ioana, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-b44bf7f2-97da-4b61-a6ec-4deab2150806.
=============================================================


Frame	Module	Signature	Source
0	libxul.so	XPCWrappedNativeScope::MarkAllWrappedNativesAndProtos()	js/xpconnect/src/XPCInlines.h
1	libxul.so	XPCJSRuntime::FinalizeCallback(JSFreeOp*, JSFinalizeStatus, bool, void*)	js/xpconnect/src/XPCJSRuntime.cpp
2	libxul.so	js::gc::GCRuntime::callFinalizeCallbacks(js::FreeOp*, JSFinalizeStatus) const	js/src/jsgc.cpp
3	libxul.so	js::gc::GCRuntime::endSweepPhase(bool)	js/src/jsgc.cpp
4	libxul.so	js::gc::GCRuntime::incrementalCollectSlice(js::SliceBudget&, JS::gcreason::Reason)	js/src/jsgc.cpp
5	libxul.so	js::gc::GCRuntime::gcCycle(bool, js::SliceBudget&, JS::gcreason::Reason)	js/src/jsgc.cpp
6	libxul.so	js::gc::GCRuntime::collect(bool, js::SliceBudget, JS::gcreason::Reason)	js/src/jsgc.cpp
7	libxul.so	js::gc::GCRuntime::gcSlice(JS::gcreason::Reason, long)	js/src/jsgc.cpp
8	libxul.so	js::gc::GCRuntime::notifyDidPaint()	js/src/jsgc.cpp
9	libxul.so	nsXPConnect::NotifyDidPaint()	js/xpconnect/src/nsXPConnect.cpp
10	libxul.so	nsRefreshDriver::Tick(long, mozilla::TimeStamp)	layout/base/nsRefreshDriver.cpp
11	libxul.so	mozilla::RefreshDriverTimer::Tick(long, mozilla::TimeStamp)	layout/base/nsRefreshDriver.cpp
12	libxul.so	mozilla::VsyncRefreshDriverTimer::RefreshDriverVsyncObserver::TickRefreshDriver(mozilla::TimeStamp)	layout/base/nsRefreshDriver.cpp
13	libxul.so	nsRunnableMethodImpl<void (mozilla::VsyncRefreshDriverTimer::RefreshDriverVsyncObserver::*)(mozilla::TimeStamp), true, mozilla::TimeStamp>::Run()	xpcom/glue/nsThreadUtils.h
14	libxul.so	nsThread::ProcessNextEvent(bool, bool*)	xpcom/threads/nsThread.cpp
15	libxul.so	NS_ProcessNextEvent(nsIThread*, bool)	xpcom/glue/nsThreadUtils.cpp
16	libxul.so	mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*)	ipc/glue/MessagePump.cpp
17	libxul.so	MessageLoop::Run()	ipc/chromium/src/base/message_loop.cc
18	libxul.so	nsBaseAppShell::Run()	widget/nsBaseAppShell.cpp
19	libxul.so	nsAppStartup::Run()	toolkit/components/startup/nsAppStartup.cpp
20	libxul.so	XREMain::XRE_mainRun()	toolkit/xre/nsAppRunner.cpp
21	libxul.so	XREMain::XRE_main(int, char**, nsXREAppData const*)	toolkit/xre/nsAppRunner.cpp
22	libxul.so	XRE_main	toolkit/xre/nsAppRunner.cpp
23	firefox	do_main	browser/app/nsBrowserApp.cpp
24	firefox	main	browser/app/nsBrowserApp.cpp
25	libc-2.15.so	__libc_start_main	/build/buildd/eglibc-2.15/csu/libc-start.c:226
26	firefox	_init	
27	firefox	malloc_good_size	memory/build/replace_malloc.c
28	firefox	__libc_csu_fini	
29	firefox	malloc_good_size	memory/build/replace_malloc.c
30	firefox	_start
This signature spiked on the August 5 build and is very likely the same root cause as bug 1191465. If the volume goes back down in tomorrow's nightly (which is expected to have a fix) then I'll resolve this.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1191465
You need to log in before you can comment on or make changes to this bug.