Use lower memory threshold for audio only source buffer

RESOLVED DUPLICATE of bug 1216460

Status

()

P2
normal
RESOLVED DUPLICATE of bug 1216460
4 years ago
3 years ago

People

(Reporter: jya, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(firefox42 affected)

Details

(Whiteboard: [MemShrink:P2])

(Reporter)

Description

4 years ago
MediaSource currently uses a memory threshold of 100MiB for its sourcebuffers regardless of the content type.

While 100MiB is appropriate for video, for audio only sourcebuffer it doesn't make any sense.

100MiB of buffer to keep audio allows for over one hour of buffer.
This defeat the purpose of mediasource which allows to narrowly control what and how much data is fed to the media element.

Chrome according to their literature uses 150MB for video and 12MB for audio.
I think we could easily reduce it to 15MB which gives us over 9 minutes of audio buffer if we use YouTube as a reference.
Whiteboard: [MemShrink]
Whiteboard: [MemShrink] → [MemShrink:P2]
Target for 43; no need to upload to 42.

Doing this in time would make more since than size. The spec does specify sizes though, and we'd need to work with player authors to make sure they work with the buffering we provide.
Priority: -- → P2
(Reporter)

Comment 2

3 years ago
ended up being fixed in bug 1216460
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1216460
You need to log in before you can comment on or make changes to this bug.