[Contacts]Screen will flash once or twice after you tap "Find duplicate contacts"

RESOLVED FIXED in FxOS-S7 (18Sep)

Status

defect
P3
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: wenqiuhong, Assigned: arcturus)

Tracking

({regression})

unspecified
FxOS-S7 (18Sep)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master fixed)

Details

(Whiteboard: [NG Gaia Contacts][2.5-aries-test-run-1])

Attachments

(5 attachments)

[1.Description]:
[AriesKK v2.5][FlameKK v2.5][Contacts]Screen will flash once or twice after you tap "Find duplicate contacts", and the OK button will be shown incompletely on FlameKK v2.5.
See attachment: FlameKK&AriesKK and logcat_AriesKK.txt
Found at:AriesKK4:45, FlameKK8:45

[2.Testing Steps]: 
1. Launch Contact
2. Tap one contact
3. Tap "Find duplicate contacts"

[3.Expected Result]: 
3. Screen shows normally

[4.Actual Result]: 
3. Screen will flash once or twice.

[5.Reproduction build]: 
Device: Aries KK 2.5(Affected)
Build ID               20150804223818
Gaia Revision          c5425d9f1f5184731a59ed4bc99295acbde30390
Gaia Date              2015-08-04 16:09:19
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f3b757156f69
Gecko Version          42.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150804.220057
Firmware Date          Tue Aug  4 22:01:05 UTC 2015
Bootloader             s1

Device: Flame KK 2.2(Unaffected)
Build ID               20150805032505
Gaia Revision          f8b119ac30e97df991c97682ac4d4f9ca22e1793
Gaia Date              2015-07-31 13:20:55
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0c7a85251e10
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150805.065842
Firmware Date          Wed Aug  5 06:58:54 EDT 2015
Firmware Version       v18D v
Bootloader             L1TC000118D0

Device:Flame KK 2.5(Affected)
Build ID               20150805150207
Gaia Revision          581de383687dc441a878d2c91a0167c6ec688fef
Gaia Date              2015-08-05 01:48:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/b12a261ee32e
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150805.195702
Firmware Date          Wed Aug  5 19:57:12 EDT 2015
Firmware Version       v18D v
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Reporter

Comment 1

4 years ago
Posted video FlameKK_AriesKK.3gp
Reporter

Comment 2

4 years ago
Posted file logcat_AriesKK.txt
Reporter

Comment 3

4 years ago
Posted file logcat_FlameKK.txt
[Blocking Requested - why for this release]: Visual regression that happened in 2.5.
blocking-b2g: --- → 2.5?
Comms triage: This might be a graphics issue due to the new API used. Do you know who we could ping in the Graphics issue, No-Jun?
Flags: needinfo?(npark)
kats would be the best person to talk to, although these might be two separate problems.  Kats, could you take a look and see whether it's some kind of a layers issue?
Flags: needinfo?(npark) → needinfo?(bugmail.mozilla)
The two issues look like separate issues. The Aries flashing might be a graphics issue but the Flame one doesn't look like graphics. Either of them might also be bugs in the Contacts app so I would ask that the Contacts app owners investigate this first.
Flags: needinfo?(bugmail.mozilla)
Comms triage: Visible regression. Due to comment 7, this might be in Contacts. Borja, can you take a look?
blocking-b2g: 2.5? → 2.5+
Flags: needinfo?(borja.bugzilla)
Depends on: 1180627
I tried to did something on flame-kk to verify this issue.

1. My local build with the following git history didn't have this issue.
   Gecko : 12c14bd758a0d2a41a6b825bef5836559a82b01a
   Gaia : 38ad6b7600ed6327bed542517258af0020fefd78

2. Sync with today's flame-kk build, 
   Gecko : commit d8c72cf74c1d02c1a8b4416abf8debc136e60fb1
   Gaia : commit 60489c1ff8c5d1633fc4837d4f8019623d4e1940

   Firstly I tried to only flash Gecko based on 1, the issue still not happen. And then, I tried to flash gaia, the issue finally could be reproduced.

   Based on the above steps, I think it should be a gaia regression. Does anyone can help on the following thing? Thanks
Hi Vincent,

I'm sure it is a gaia regression. What it's happening is that we load with a window.open a url that contains an ui (white with a red button in the bottom), and inmediately when the js is loaded we change to the message in greay saying we could not find duplicates.
After working a bit on the bug, soon will post a wip, I realised that aries devices shows a pink glitch on the middle of some transitions that doesn't happen in  flame.
Posted file WIP
Attachment #8649248 - Flags: feedback?(borja.bugzilla)
Assignee: nobody → francisco
Status: NEW → ASSIGNED
Flags: needinfo?(borja.bugzilla)
Whiteboard: [2.5-aries-test-run-1] → [NG Gaia Contacts][2.5-aries-test-run-1]
Target Milestone: --- → FxOS-S6 (04Sep)
Comment on attachment 8649248 [details] [review]
WIP

Despite on it's working, Im wondering if we would nee to show this prompt 1 second in a high end device... Why dont we remove the prompt? Why do we need it? Thanks!
Attachment #8649248 - Flags: feedback?(borja.bugzilla) → feedback+
Flags: needinfo?(francisco)
Marking as P3
Priority: -- → P3
Target Milestone: FxOS-S6 (04Sep) → FxOS-S7 (18Sep)
We need it cause in devices like flame it could take more than 2 seconds (if you go for a high load), and if we don't display anything seems the app is not working.
Flags: needinfo?(francisco)
Attachment #8649248 - Flags: review?(borja.bugzilla)
Attachment #8649248 - Flags: review?(borja.bugzilla) → review+
Landed:

https://github.com/mozilla-b2g/gaia/commit/1ebec25fa866bae69ef96367efcaf92ff1299a70
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Tested in latest master build (9/9) and I cannot reproduce the issue. Thanks Francisco!

Environmental Variables (9/9):
flame master (2.5 version)
Build ID: 20150909070122
Gecko: eea972e
Gaia: 404a35a
Platform version: 43.0a1
Hi Francisco,
Thanks for the fix, and now it looks much better. But after double check with Flame v2.2, I find that on the latest build of Aries KK&Flame KK v2.5 , it still flashes slightly after tapping the "Find duplicate contacts" button, I have uploaded the contrast video of Flame v2.2&AriesKK v2.5, would you help to check? Thanks.

Device: AreisKK v2.5(Affected)
Build ID               20150909215153
Gaia Revision          47459eead04385e22f967012b824f5abdddcfb7c
Gaia Date              2015-09-09 10:37:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dd2a1d737a64d9a3f23714ec5cc623ec8933b51f
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150909.211310
Firmware Date          Wed Sep  9 21:13:17 UTC 2015
Bootloader             s1

Device:Flame KK 2.5(Affected)
Build ID               20150909150223
Gaia Revision          47459eead04385e22f967012b824f5abdddcfb7c
Gaia Date              2015-09-09 10:37:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dd2a1d737a64d9a3f23714ec5cc623ec8933b51f
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150909.185733
Firmware Date          Wed Sep  9 18:57:43 EDT 2015
Firmware Version       v18D v
Bootloader             L1TC000118D0
Flags: needinfo?(francisco)
Reporter

Updated

4 years ago
QA Whiteboard: [MGSEI-Triage+]
What it's happening is that we are opening a new window and we show the background.

With this new solution for having news in different documents until we have the pre-rendering we will have situations where we will see for a while the background.
Flags: needinfo?(francisco)
You need to log in before you can comment on or make changes to this bug.