Closed Bug 1191965 Opened 7 years ago Closed 2 years ago

Use CoreAnimation like HardwareComposer

Categories

(Core :: Graphics: Layers, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1429522
Performance Impact none

People

(Reporter: jrmuizel, Unassigned)

References

Details

(Whiteboard: [gfx-noted])

It's possible to set the contents of CALayers to IOSurfaces. We could use this to implement a more efficient compositing path for things like video or WebGL (especially in fullscreen)

The idea would be to detect when we can draw using CoreAnimation instead of OpenGL just like we do with HardwareComposer.

Chrome did something like this in https://code.google.com/p/chromium/issues/detail?id=510252

We might also be able to do something like this with DirectComposition (however we have partial-present on Windows so it's not as important)
See Also: → 1191971
Blocks: 1190409
Whiteboard: [gfx-noted]
Assignee: nobody → tnikkel
Priority: P3 → P1
Blocks: 1423324
Depends on: 1429522
Whiteboard: [gfx-noted] → [gfx-noted][qf]
Whiteboard: [gfx-noted][qf] → [gfx-noted][qf:f64][qf:63]
Whiteboard: [gfx-noted][qf:f64][qf:63] → [gfx-noted][qf:f64][qf:p3]
Note targeting qf:64 "seems reasonable" but note gfx team is very early on in figuring out how to render with CoreAnimation in Firefox. So as we learn about current unknowns there, we'll better understand estimation here.
Whiteboard: [gfx-noted][qf:f64][qf:p3] → [gfx-noted][qf:f64][qf:p1]
Whiteboard: [gfx-noted][qf:f64][qf:p1] → [gfx-noted][qf:p1:f64]
Jeff (or someone) can you explain the impact fixing this bug will have (to help QF understanding/planning)?
Flags: needinfo?(jmuizelaar)
Using CoreAnimation can help improve memory bandwidth usage which can help with battery life.
Flags: needinfo?(jmuizelaar)

(QF is already tracking bug 1429522, so I'm qf-minusing this one.)

Whiteboard: [gfx-noted][qf:p1:f64] → [gfx-noted][qf-]
Assignee: tnikkel → nobody
Priority: P1 → P3
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1429522
Performance Impact: --- → -
Whiteboard: [gfx-noted][qf-] → [gfx-noted]
You need to log in before you can comment on or make changes to this bug.