All users were logged out of Bugzilla on October 13th, 2018

Poor scrolling performance on http://kangax.github.io/compat-table/es6/, due to CSS filter rendering

RESOLVED DUPLICATE of bug 1267898

Status

()

RESOLVED DUPLICATE of bug 1267898
3 years ago
a year ago

People

(Reporter: daniel.nr01, Assigned: tschneider)

Tracking

({perf})

42 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox39 affected, firefox40 affected, firefox41 affected, firefox42 affected, firefox-esr31 unaffected, firefox-esr38 affected)

Details

(URL)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150806030205

Steps to reproduce:

* Visit http://kangax.github.io/compat-table/es6/
* Scroll the page

I'm running latest Nightly on Windows 7 64-bit.


Actual results:

The scrolling is janky. By recording a session with the preformance devtools you can see that almost all time is spent in painting and that we get a very low avg fps.


Expected results:

The scrolling should be smooth as in IE 11 and Chrome 44.
(Reporter)

Updated

3 years ago

Updated

3 years ago
Component: Untriaged → Untriaged
Product: Firefox → Core

Comment 1

3 years ago
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9b157630e5ab&tochange=697c4b245de0

Triggered by: 697c4b245de0	Tim Nguyen — Bug 1057180 - Enable CSS Filters by default. r=dbaron
Blocks: 1057180
Status: UNCONFIRMED → NEW
status-firefox39: --- → affected
status-firefox40: --- → affected
status-firefox41: --- → affected
status-firefox42: --- → affected
status-firefox-esr31: --- → unaffected
status-firefox-esr38: --- → affected
Ever confirmed: true
Keywords: perf
Flags: needinfo?(ntim.bugs)
Flags: needinfo?(dbaron)
Flags: needinfo?(ntim.bugs)
Flags: needinfo?(mvujovic)
Flags: needinfo?(mstange)
Flags: needinfo?(dbaron)
Summary: Poor scrolling performance on http://kangax.github.io/compat-table/es6/ → Poor scrolling performance on http://kangax.github.io/compat-table/es6/, due to CSS filter rendering

Comment 3

3 years ago
Deferring needinfo to Markus, since I'm not working on Firefox these days.
Flags: needinfo?(mvujovic)
This one needs a closer look...
Flags: needinfo?(bugs)
To Tobias for profiling and diagnosis.
Assignee: nobody → tschneider
Flags: needinfo?(mstange)
Flags: needinfo?(bugs)
(Assignee)

Comment 6

3 years ago
After profiling and talking to Markus, the poor scrolling performance seems to be related to https://bugzilla.mozilla.org/show_bug.cgi?id=975644, not canvas filters.
(Assignee)

Updated

3 years ago
Depends on: 975644
I think we can close this as a dupe of Bug 1267898 (which depends on Bug 975644), since it's really about "fake" position: sticky performance (because we don't support pos:sticky on thead yet). 

(Or we can close the other as a dupe of this and update the title)

WDYT Tobias?
Flags: needinfo?(tschneider)
(Assignee)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(tschneider)
Resolution: --- → DUPLICATE
Duplicate of bug: 1267898
You need to log in before you can comment on or make changes to this bug.