Closed Bug 1192211 Opened 4 years ago Closed 4 years ago

browser_urlbar_autoFill_backspaced.js is going to permafail when Gecko 42 merges to Aurora

Categories

(Firefox :: Address Bar, defect, critical)

defect
Not set
critical

Tracking

()

VERIFIED FIXED
Firefox 42
Tracking Status
firefox42 --- verified

People

(Reporter: RyanVM, Assigned: adw)

References

Details

Attachments

(1 file)

.includes is still nightly-only. Please fix ASAP given where we are in the cycle.

https://treeherder.mozilla.org/logviewer.html#?job_id=10214803&repo=try

21:45:24 INFO - 646 INFO TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_urlbar_autoFill_backspaced.js | Uncaught exception - at chrome://mochitests/content/browser/browser/base/content/test/general/browser_urlbar_autoFill_backspaced.js:24 - TypeError: types.includes is not a function
Flags: needinfo?(mak77)
I'll fix this today since Marco's away.
Assignee: nobody → adw
Status: NEW → ASSIGNED
Flags: needinfo?(mak77)
Attached patch patchSplinter Review
Attachment #8645043 - Flags: review?(dtownsend)
Attachment #8645043 - Flags: review?(dtownsend) → review+
https://hg.mozilla.org/mozilla-central/rev/fba73d3a3792
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 42
This is consistently hitting a new error now:

https://treeherder.mozilla.org/logviewer.html#?job_id=10247289&repo=try

707 INFO TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_urlbar_autoFill_backspaced.js | A promise chain failed to handle a rejection: - at chrome://mochikit/content/browser-test.js:752 - TypeError: this.SimpleTest.isExpectingUncaughtException is not a function
Status: RESOLVED → REOPENED
Flags: needinfo?(adw)
Resolution: FIXED → ---
The failure seems to be caused by browser_urlbarSearchSuggestionsNotification.js

 20:33:55 INFO - 649 INFO TEST-START | browser/base/content/test/general/browser_urlbar_autoFill_backspaced.js
20:33:56 INFO - *************************
20:33:56 INFO - A coding exception was thrown and uncaught in a Task.
20:33:56 INFO - Full message: TypeError: Assert is null
20:33:56 INFO - Full stack: focus_allSuggestionsDisabled@chrome://mochitests/content/browser/browser/base/content/test/general/browser_urlbarSearchSuggestionsNotification.js:33:3 

I don't think this should be reopened, it's clear a previous test is causing this one to fail.
Flags: needinfo?(adw) → needinfo?(ryanvm)
OK, thanks for checking.
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Flags: needinfo?(ryanvm)
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.