Closed Bug 1192441 Opened 5 years ago Closed 5 years ago

DOM Push service defaults to spamming the console

Categories

(Core :: DOM: Push Notifications, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla42
Tracking Status
firefox42 --- fixed

People

(Reporter: mossop, Assigned: mossop)

References

Details

The default here is to log messages to the console, our normal policy is to not log by default and control with prefs which seems to be what the comment suggests should happen. Is this meant to be turned on? Can we turn it off?

https://hg.mozilla.org/mozilla-central/annotate/d6ea652c579992daa9041cc9718bb7c6abefbc91/dom/push/PushService.jsm#l8
Flags: needinfo?(dougt)
Blocks: 1038811
Duplicate of this bug: 1192420
yes. r+
Flags: needinfo?(dougt)
Assignee: nobody → dtownsend
https://hg.mozilla.org/mozilla-central/rev/7ece2ae55806
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
You need to log in before you can comment on or make changes to this bug.