Closed Bug 1192469 Opened 7 years ago Closed 7 years ago

Clockwork Empires website scrolls horribly in e10s

Categories

(Core :: Layout, defect)

x86
Windows 8.1
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
e10s - ---
firefox42 --- affected

People

(Reporter: Hughman, Unassigned)

References

()

Details

Scrolling, especially using the scrollbar, on the Clockwork Empires website is extremely laggy with e10s enabled.

It is much better with e10s disabled (though not as good as IE11).

For another note the scrolling using mouse wheel is very responsive in e10s but the background and menu lag behind extremely badly.
Component: General → Untriaged
Product: Firefox → Core
Hugh, is this reproducible with all of your add-ons disabled?
Flags: needinfo?(hughnougher)
Just did another test with updated nightly.
Absolutely no difference between a new profile and my normal one.

Also the scrolling response is a little bit better now compared to the other day.
Non e10s is pretty much the same as IE11.
e10s version is still quite horrible.
Flags: needinfo?(hughnougher)
Hugh, can you try turning off APZ in about:config.
Flags: needinfo?(hughnougher)
I was able to reproduce, and disabling APZ (by setting layers.async-pan-zoom.enabled to false and restarting) made it better.

Hugh, can you confirm?
Confirmed.

Its smooth with that setting disabled.
Flags: needinfo?(hughnougher)
Hey - is there an APZ perf bug somewhere?
Flags: needinfo?(bugmail.mozilla)
(In reply to Hugh Nougher [:Hughman] from comment #0)
> Scrolling, especially using the scrollbar, on the Clockwork Empires website
> is extremely laggy with e10s enabled.
> 
> It is much better with e10s disabled (though not as good as IE11).
> 
> For another note the scrolling using mouse wheel is very responsive in e10s
> but the background and menu lag behind extremely badly.

There's two issues here. One is that with APZ enabled and mousewheel scrolling, the background and menu lag. This is because of bug 1166301.

The other is that "scrolling using the scrollbar is laggy" but "scrolling using the mouse wheel is very responsive" - this indicates that the non-APZ codepaths (i.e. dragging the scrollbar) are slow but the APZ codepaths (mouse wheel) are fast.

Since we already have bug 1166301 to track the first issue, let's use this bug to track the second issue.
Blocks: apz-desktop
Component: Untriaged → Layout
Depends on: 1166301
Flags: needinfo?(bugmail.mozilla)
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #7)
> (In reply to Hugh Nougher [:Hughman] from comment #0)
> > Scrolling, especially using the scrollbar, on the Clockwork Empires website
> > is extremely laggy with e10s enabled.
> > 
> > It is much better with e10s disabled (though not as good as IE11).
> > 
> > For another note the scrolling using mouse wheel is very responsive in e10s
> > but the background and menu lag behind extremely badly.
> 
> There's two issues here. One is that with APZ enabled and mousewheel
> scrolling, the background and menu lag. This is because of bug 1166301.
> 
> The other is that "scrolling using the scrollbar is laggy" but "scrolling
> using the mouse wheel is very responsive" - this indicates that the non-APZ
> codepaths (i.e. dragging the scrollbar) are slow but the APZ codepaths
> (mouse wheel) are fast.
> 
> Since we already have bug 1166301 to track the first issue, let's use this
> bug to track the second issue.

Will this bug also cover enabling auto scrolling via the APZ codepath or should we open up a new one for it?
As auto scrolling on this site is horrific versus the silky smooth mousewheel scrolling which is APZ enabled.
tracking-e10s: --- → -
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #7)
> (In reply to Hugh Nougher [:Hughman] from comment #0)
> > Scrolling, especially using the scrollbar, on the Clockwork Empires website
> > is extremely laggy with e10s enabled.
> > 
> > It is much better with e10s disabled (though not as good as IE11).
> > 
> > For another note the scrolling using mouse wheel is very responsive in e10s
> > but the background and menu lag behind extremely badly.
> 
> There's two issues here. One is that with APZ enabled and mousewheel
> scrolling, the background and menu lag. This is because of bug 1166301.
> 
> The other is that "scrolling using the scrollbar is laggy" but "scrolling
> using the mouse wheel is very responsive" - this indicates that the non-APZ
> codepaths (i.e. dragging the scrollbar) are slow but the APZ codepaths
> (mouse wheel) are fast.
> 
> Since we already have bug 1166301 to track the first issue, let's use this
> bug to track the second issue.

I tested the page with the patches in bug 1166301 applied. It looks much better, but the background still "lags" a bit - it looks like content is scrolling it slightly in response to scroll events. Not sure if there's anything we can do about that.
Testing this in Nightly now its working very well.
Non-e10s is slightly smoother than e10s but its hardly noticeable.
Thanks for everyone's work.

Is that enough to close this?
Since you filed the bug, if you are happy with the way things are now we can definitely close it. I think there are already other bugs that cover the remaining issues and if not we can file some.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.