Closed Bug 1192480 Opened 6 years ago Closed 6 years ago

SearchTests.testURLBarContextMenu times out on iPad

Categories

(Firefox for iOS :: Build & Test, defect)

All
iOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
fxios + ---

People

(Reporter: rnewman, Assigned: fluffyemily)

Details

Attachments

(1 file)

47 bytes, text/x-github-pull-request
sleroux
: review+
Details | Review
Test Failure in firefox-ios/UITests/SearchTests.swift
-[SearchTests testURLBarContextMenu()]
The step timed out after 10.00 seconds: (null)


Hanging line:

        BrowserUtils.ensureAutocompletionResult(tester(), textField: textField, prefix: "http", completion: endingString)



"http" is visible in the URL bar. No completions.
Assignee: nobody → etoop
Attached file Pull request
Not an actual failure of functionality but caused by persisted history items across tests screwing up autocomplete.

No need to rush this review for V1 release
Attachment #8647091 - Flags: review?(sleroux)
Comment on attachment 8647091 [details] [review]
Pull request

Looks good - just a comment nit. Test works great for me.
Attachment #8647091 - Flags: review?(sleroux) → review+
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.