Closed Bug 1192571 Opened 9 years ago Closed 9 years ago

Dragging a youtube tab to another window in e10s mode makes the video go black

Categories

(Core :: Audio/Video, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla43
Tracking Status
e10s m8+ ---
firefox43 --- fixed

People

(Reporter: ehsan.akhgari, Assigned: mattwoodrow)

References

Details

Attachments

(1 file)

STR: Load a youtube video, and drag it either to another window or detach it to make it become its own window.  The video goes black.

Surprisingly, if you drag the tab back to its original window, the video paints correctly again.

This only happens in e10s mode.
I can repro on Mac 10.9.5.  It works on a build from mid July, so it seems it's a recent regression.  I'll track down that regression-window shortly.
Flags: needinfo?(twalker)
Turns out, it regressed last night.  Something that landed for today's build, http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0e269a1f1beb&tochange=8cba870a352c, caused this bug:
Flags: needinfo?(twalker)
Assignee: nobody → jmathies
Matt could the fix for bug 1061525 have caused this?
Flags: needinfo?(matt.woodrow)
Yes, that seems likely.
Assignee: jmathies → matt.woodrow
Flags: needinfo?(matt.woodrow)
Attachment #8646638 - Flags: review?(jmuizelaar)
Attachment #8646638 - Flags: review?(jmuizelaar) → review+
https://hg.mozilla.org/mozilla-central/rev/d3f4668bcb0a
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
Blocks: 1061525
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: