Button to open add-on preferences page (em:optionsType=3) is missing in Fennec

RESOLVED WONTFIX

Status

()

Firefox for Android
Add-on Manager
RESOLVED WONTFIX
3 years ago
a month ago

People

(Reporter: Mindaugas <LA-MJ>, Unassigned)

Tracking

Trunk
Unspecified
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.26 Safari/537.36
Firefox for Android

Steps to reproduce:

Created an add-on with 
> <em:optionsURL>chrome://addon/content/preferences.html</em:optionsURL>
> <em:optionsType>3</em:optionsType>
in install.rdf


Actual results:

There is no button to open add-on preferences in about:addons on Firefox for Android. Only disable & uninstall buttons are shown.

The issue has been there for as long as I remember and persists in fennec nightly (v42).


Expected results:

Fennec should automatically render preferences button to open optionsURL just like in desktop Firefox.
(Reporter)

Updated

3 years ago
Component: Untriaged → Add-on Manager
OS: Unspecified → Android
Product: Firefox → Firefox for Android
Do we think this makes sense on FxAndroid?
Flags: needinfo?(margaret.leibovic)
(Reporter)

Comment 2

3 years ago
How could it not make sense if XUL is officially being phased out?

Comment 3

3 years ago
We do support options.xul. See a demo add-on here:
https://github.com/leibovic/options-kitchen-sink/

I'm just not sure that we support the optionsType 3.

There are lots of problems with our current implementation, and I have this bug on file to track them and where I proposed a solution to get rid of XUL:
https://bugzilla.mozilla.org/show_bug.cgi?id=1079466
Depends on: 1079466
Flags: needinfo?(margaret.leibovic)
(Reporter)

Comment 4

3 years ago
Like I said, optionsType=3 is supported on desktop but not on mobile.

And options.xul is not a solution because XUL is deprecated.
Inline options of add-ons built by jpm never worked on fennec, even though cfx has been deprecated for quite a while.

Comment 7

a month ago
Firefox 57 only WebExtensions are supported, and their options work.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a month ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.