very common crashes [@ EnterBaseline ] (possibly a system-level problem?)

RESOLVED INCOMPLETE

Status

()

Core
JavaScript Engine
RESOLVED INCOMPLETE
3 years ago
3 years ago

People

(Reporter: Thomas Jakway, Unassigned)

Tracking

(Blocks: 1 bug, {crash})

Trunk
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20151019] , crash signature)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8645510 [details]
Report

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150806191835

Steps to reproduce:

This bug happens on all websites, but more complicated ones seem to trigger it more often.  Facebook is a notable source of problems.


Actual results:

Firefox version 39.0.3
64-bit Ubuntu 15.04, Processor: AMD Phenom(tm) II X6 1090T Processor × 6, Graphics: Gallium 0.4 on AMD PITCAIRN
Firefox crashes frequently (usually every 5-10 minutes, but it varies a lot: sometimes every minute, sometimes only once an hour).  This doesn't seem limited to Firefox (though Firefox may be triggering it in unique ways); every browser I've tried so far has crashed eventually: Chrome, Qupzilla, and the Ubuntu web browser from the webbrowser-app package.
This bug has existed since I installed Ubuntu.
Alternative graphics drivers have no effect.  I've tried the fglrx package and AMD's fglrx beta drivers, both with and without updates.  I have also tried 32-bit versions to no effect.
Problem does not occur running Windows on the same computer.
Sorry if I haven't filled this out correctly, it's my first time filing a bug report.  This has been a serious pain.
(Reporter)

Updated

3 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Comment 1

3 years ago
Thanks for getting through bugzilla and reporting this issue!

Please comment with the crash report URL: https://developer.mozilla.org/en-US/docs/How_to_get_a_stacktrace_for_a_bug_report#How_to_get_a_crash_ID_with_the_Mozilla_Crash_Reporter - the file you attached is not a full crash report. Why do you say the crashes are driver-related?
Flags: needinfo?(thomasjakway1)
(Reporter)

Updated

3 years ago
Flags: needinfo?(thomasjakway1)
Comment hidden (obsolete)
Comment hidden (obsolete)
Comment hidden (obsolete)
(Reporter)

Updated

3 years ago
Comment hidden (obsolete)

Comment 6

3 years ago
>> Why do you say the crashes are driver-related?
> The report lists "OpenGL: X.Org -- Gallium 0.4 on AMD PITCAIRN -- 3.0 Mesa 10.5.2 -- texture_from_pixmap" 
> which looks like a graphics driver issue.  No idea why though

I believe we just unconditionally add some information about the graphics on your system to each crash report (to help troubleshooting the crashes that *are* driver-related):
http://hg.mozilla.org/mozilla-central/annotate/2ddfc9180971/widget/GfxInfoX11.cpp#l189

The crashes you listed do not seem to implicate graphics in any way. Of the 5 crashes you posted,
* 3 are from a nightly build:
** bp-9ccd4cf6-58eb-4d9d-831e-987f32150815 [@ void DoMarking<T>(js::GCMarker*, js::jit::JitCode*) ] in GC
** bp-f911650a-a92a-4adc-b8da-6eb462150815 [@ libuuid.so.1.3.0@0x8957c ] inside EnterBaseline
** bp-e7bc30a6-4866-43bb-916a-d4a9a2150815 [@ EnterBaseline ] (content process)
* 2 are from v40.0:
** bp-ef7a6176-7d3b-4a9f-b353-299122150815 [@ js::num_toString ] (failed to unwind the stack)
** bp-05338802-c275-4fde-9c0b-e0c102150814 [@ EnterBaseline ]

Unfortunately, as far as I can see, none of the crash reports point to the source of the problem. EnterBaseline, in particular, is the generic signature for crashes inside the JIT-compiled code (cf. bug 858032), and GC crashes are usually caused by the problems not captured in the stack trace.

I see from the crash reports that you don't have extensions installed, but just to make sure -- does the problem reproduce in a new profile <https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles> with all the plugins disabled?

Also, since you mention general instability, I would guess there might be a problem with HW (but you say Windows on the same computer runs fine...) or with the system (can you reproduce with a stock install of Ubuntu? Do you run it via dual-booting or inside a VM?)
Blocks: 858032
Crash Signature: [@ EnterBaseline ]
Component: Untriaged → JavaScript Engine
Keywords: crash
Product: Firefox → Core
Summary: Driver-related crashes with Radeon R9 2xxx Series → very common crashes [@ EnterBaseline ] (possibly a system-level problem?)
Version: 39 Branch → Trunk
(Reporter)

Comment 7

3 years ago
(In reply to Nickolay_Ponomarev from comment #6)
> >> Why do you say the crashes are driver-related?
> > The report lists "OpenGL: X.Org -- Gallium 0.4 on AMD PITCAIRN -- 3.0 Mesa 10.5.2 -- texture_from_pixmap" 
> > which looks like a graphics driver issue.  No idea why though
> 
> I believe we just unconditionally add some information about the graphics on
> your system to each crash report (to help troubleshooting the crashes that
> *are* driver-related):
> http://hg.mozilla.org/mozilla-central/annotate/2ddfc9180971/widget/
> GfxInfoX11.cpp#l189
> 
> The crashes you listed do not seem to implicate graphics in any way. Of the
> 5 crashes you posted,
> * 3 are from a nightly build:
> ** bp-9ccd4cf6-58eb-4d9d-831e-987f32150815 [@ void
> DoMarking<T>(js::GCMarker*, js::jit::JitCode*) ] in GC
> ** bp-f911650a-a92a-4adc-b8da-6eb462150815 [@ libuuid.so.1.3.0@0x8957c ]
> inside EnterBaseline
> ** bp-e7bc30a6-4866-43bb-916a-d4a9a2150815 [@ EnterBaseline ] (content
> process)
> * 2 are from v40.0:
> ** bp-ef7a6176-7d3b-4a9f-b353-299122150815 [@ js::num_toString ] (failed to
> unwind the stack)
> ** bp-05338802-c275-4fde-9c0b-e0c102150814 [@ EnterBaseline ]
> 
> Unfortunately, as far as I can see, none of the crash reports point to the
> source of the problem. EnterBaseline, in particular, is the generic
> signature for crashes inside the JIT-compiled code (cf. bug 858032), and GC
> crashes are usually caused by the problems not captured in the stack trace.
> 
> I see from the crash reports that you don't have extensions installed, but
> just to make sure -- does the problem reproduce in a new profile
> <https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-
> firefox-profiles> with all the plugins disabled?
> 
> Also, since you mention general instability, I would guess there might be a
> problem with HW (but you say Windows on the same computer runs fine...) or
> with the system (can you reproduce with a stock install of Ubuntu? Do you
> run it via dual-booting or inside a VM?)

I'm so sorry for the very late response.  It's been a very long and unusual week.  I'll do everything I can to respond faster in the future.
Firefox on Windows does crash but far less frequently, maybe once every few days.  Sorry for being misleading about that.

Those crash reports are from a nightly build because I downloaded a nightly build so it would have debug symbols.  I will reproduce the bug on whatever version/build you like, just post a link.  It doesn't seem to make a difference from a user perspective what version I run, they're all equally affected.
I dual boot Windows and Linux.  I tested it on a clean Ubuntu install and on a live USB—the bug still behaved exactly the same.
Crash reports from live USB (nightly build):
bp-06d8d9f1-9345-4dff-b27f-c0e872150822
bp-b4ea764e-bebc-43b9-b2ec-dfc8b2150822
bp-084d60c6-f889-4b75-ad1b-f4e5b2150822
bp-0f018f89-b434-4b53-89d5-4f1f32150822

Crash reports from a clean Ubuntu install:
bp-3011b737-95f0-473a-bc70-ae2472150821
bp-a9b9b994-7dd2-43ec-8451-705052150821
bp-ef8eb8e9-0fe5-418d-b723-9f0e62150821

Crash reports from Windows (these don't have symbols because they're old.  I'm running a nightly build as my default browser now but it doesn't crash very often, I will post a crash report if it does.  Sorry if they aren't very helpful.  At the very least it's a demonstration that it isn't just Linux):
bp-c24a241d-77a5-4329-844b-9c1cd2150820
bp-690fb270-b198-4fdd-8b2a-812402150815
bp-79ed57d6-74ea-4284-b485-e51632150815
bp-528d9344-a904-42f7-9a80-2db6c2150813
bp-c68805f8-f487-473b-8d47-0c82d2150812
bp-97a0aca0-1ecd-4079-8dba-6f79b2150812
bp-45298e0f-9b93-432d-af00-6463e2150810
bp-34440460-374a-4f74-be56-caadf2150809
bp-e3414aa7-9867-4c4a-b8d2-63db82150809
bp-53c8434a-8b91-4813-87d9-03a562150808

Thanks for your attention!

Comment 8

3 years ago
Sorry, I'm out of ideas. Perhaps someone else will see something I don't, but to me this does look like a system-level (hardware?) problem.

I'd start by running hardware-level diagnostics (memtest and so on), but I haven't done that in a long time, so I won't be able to help with more specific suggestions.
(Reporter)

Comment 9

3 years ago
Oh well, thanks for your time all the same!
I ran memtest last week and all results were normal but I'll see if I can find some other hardware tests.

Comment 10

3 years ago
¡Hola Thomas!

Is this still a problem?

If so, do you happen to have more precise steps to reproduce the crash now?

Else, please mark this RESOLVED WORKSFORME in Status at the bottom of 

¡Gracias!
Alex
Flags: needinfo?(thomasjakway1)
Whiteboard: [bugday-20151019] [closeme-20151102]

Comment 11

3 years ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(thomasjakway1)
Resolution: --- → INCOMPLETE
Whiteboard: [bugday-20151019] [closeme-20151102] → [bugday-20151019]
You need to log in before you can comment on or make changes to this bug.