Closed Bug 1192693 Opened 5 years ago Closed 5 years ago

Remove bluetooth1 code from Bluetooth

Categories

(Firefox OS Graveyard :: Bluetooth, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(firefox43 fixed)

RESOLVED FIXED
FxOS-S5 (21Aug)
Tracking Status
firefox43 --- fixed

People

(Reporter: ben.tian, Assigned: ben.tian)

References

Details

(Keywords: dev-doc-needed)

Attachments

(3 files, 2 obsolete files)

Remove bluetooth1 code since we've moved to bluetooth2 on m-c.
Assignee: nobody → btian
Attachment #8645534 - Flags: review?(joliu)
Comment on attachment 8645535 [details] [diff] [review]
[final] Patch 3: Remove bluetooth1 code from backend, r=tzimmermann

Review of attachment 8645535 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/bluetooth/bluedroid/BluetoothServiceBluedroid.cpp
@@ +635,2 @@
>          DispatchReplySuccess(mRequests[0].mRunnable,
>                               mRequests[0].mDevicesPack);

Note I decide to adopt bluetooth1 semantics here for comment above [1].

[1] https://dxr.mozilla.org/mozilla-central/source/dom/bluetooth/bluedroid/BluetoothServiceBluedroid.cpp#868
Comment on attachment 8645535 [details] [diff] [review]
[final] Patch 3: Remove bluetooth1 code from backend, r=tzimmermann

Review of attachment 8645535 [details] [diff] [review]:
-----------------------------------------------------------------

Yeah! \o/
Attachment #8645535 - Flags: review?(tzimmermann) → review+
Break original patch 1 into 2 patches to keep hg history of new webidl file. The is the first patch.
Attachment #8645534 - Attachment is obsolete: true
Attachment #8645534 - Flags: review?(joliu)
Attachment #8646174 - Flags: review?(joliu)
Comment on attachment 8645535 [details] [diff] [review]
[final] Patch 3: Remove bluetooth1 code from backend, r=tzimmermann

Re-number to patch 3.
Attachment #8645535 - Attachment description: Patch 2 (v1): Remove bluetooth1 code from backend → [final] Patch 3: Remove bluetooth1 code from backend, r=tzimmermann
Comment on attachment 8646174 [details] [diff] [review]
[final] Patch 1: Remove bluetooth manager, adapter, and device webidl files, r=joliu

Review of attachment 8646174 [details] [diff] [review]:
-----------------------------------------------------------------

Please point out these are legacy files in the commit log.
Attachment #8646174 - Flags: review?(joliu) → review+
Comment on attachment 8646175 [details] [diff] [review]
[final] Patch 2: Remove bluetooth1 folder and rename webidl files, r=joliu

Review of attachment 8646175 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, thanks a lot for the effort!
Please help to open a follow up bug to mv files under dom/bluetooth/bluetooth2 to dom/bluetooth or any other better places.
Attachment #8646175 - Flags: review?(joliu) → review+
Duplicate of this bug: 1175130
Attachment #8646174 - Attachment description: Patch 1 (v1): Remove bluetooth manager, adapter, and device webidl files → [final] Patch 1: Remove bluetooth manager, adapter, and device webidl files, r=joliu
Attachment #8646175 - Attachment description: Patch 2 (v1): Remove bluetooth1 folder and rename webidl files → [final] Patch 2: Remove bluetooth1 folder and rename webidl files, r=joliu
Keywords: checkin-needed
This is apparently missing review by a DOM peer for the webidl changes, so I can't land these. :(
Flags: needinfo?(btian)
Keywords: checkin-needed
(In reply to Wes Kocher (:KWierso) from comment #12)
> This is apparently missing review by a DOM peer for the webidl changes, so I
> can't land these. :(

Sorry my bad. I forgot the DOM peer review.
Flags: needinfo?(btian)
Comment on attachment 8646174 [details] [diff] [review]
[final] Patch 1: Remove bluetooth manager, adapter, and device webidl files, r=joliu

Blake,

Can you help review my patches that remove legacy bluetooth API webidl files?

There are two patches: the first patch removes legacy bluetooth webidl files, and the second one renames new webidl files and does the rest of the change. The reason to break into two patches is to keep hg history of new webidl files per comment 5.
Attachment #8646174 - Flags: review?(mrbkap)
Attachment #8646175 - Flags: review?(mrbkap)
Revise commit log.
Attachment #8646174 - Attachment is obsolete: true
Attachment #8646174 - Flags: review?(mrbkap)
Attachment #8646733 - Flags: review?(mrbkap)
Attachment #8646175 - Flags: review?(mrbkap) → review+
Attachment #8646733 - Flags: review?(mrbkap) → review+
Blocks: 1195597
You need to log in before you can comment on or make changes to this bug.