Last Comment Bug 1192893 - Deactivated keywords cause the table on the keyword descriptions page to render strangely
: Deactivated keywords cause the table on the keyword descriptions page to rend...
Status: RESOLVED FIXED
:
Product: bugzilla.mozilla.org
Classification: Other
Component: User Interface (show other bugs)
: Production
: Unspecified Unspecified
-- normal (vote)
: ---
Assigned To: Byron Jones ‹:glob›
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-10 09:42 PDT by Ed Morley [:emorley]
Modified: 2015-08-10 10:03 PDT (History)
5 users (show)
See Also:
Due Date:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image Ed Morley [:emorley] 2015-08-10 09:42:17 PDT
1) Deactivate keywords
2) Visit https://bugzilla.mozilla.org/describekeywords.cgi

Expected...
Either of:
(a) deactivated keywords are hidden entirely, and "Active" column not shown in table
(b) deactivated keywords are shown, and listed as "No" under the active column

Actual...
* Deactivated keywords are not shown
* However the "Active" column heading still is
* Most importantly: the table is split (ie with a duplicate header row) in every section of rows where there would have been deactivated keywords listed

ie: search for "fixedOEM" and look just above it - you will see multiple duplicate header rows, with no content rows between them.
Comment 1 User image Byron Jones ‹:glob› 2015-08-10 09:51:14 PDT
that template starts a new table every 50 rows, regardless of visibility.

i can't think of any valid reason why we don't use a single table (i bet this is a workaround for a browser issue that was fixed more than a decade ago).
Comment 2 User image Byron Jones ‹:glob› 2015-08-10 10:01:46 PDT
To ssh://gitolite3@git.mozilla.org/webtools/bmo/bugzilla.git
   44cd792..9124d9a  master -> master
Comment 3 User image Ed Morley [:emorley] 2015-08-10 10:03:44 PDT
Thank you :-)

Note You need to log in before you can comment on or make changes to this bug.