Closed Bug 1192933 Opened 5 years ago Closed 4 years ago

Fennec never given "Use the App" button if user has Google Docs installed

Categories

(Web Compatibility :: Mobile, defect)

defect
Not set
normal

Tracking

(platform-rel +, firefox43 affected)

RESOLVED FIXED
Tracking Status
platform-rel --- +
firefox43 --- affected

People

(Reporter: Swarnava, Assigned: karlcow)

References

()

Details

(Whiteboard: [country-all][sitewait][clientsniff][platform-rel-Google][platform-rel-GoogleDocs])

Attachments

(1 file)

1) Install Google Docs app from playstore.
2) Navigate to: https://goo.gl/XDWKfX
3) Click on edit button on top right cornor.

Expected Behavior:  a popup should appear which will ask to use the app instead of browser.

Actual Behavior: On Fennec, its still showing get the app button instead of Use the app button
So it does look like this is a tech evangelism issue -- if you spoof as Chrome it works as expected.

Basically it boils down to the following: https://gist.github.com/miketaylr/3835cb5ba53315fcb502

If you don't have the substring "Chrome" or "CriOS", you'll never get the OPEN IN APP link.

There's a function Lb which contains:

> b = a.wa ? b + "USE THE APP" : b + "GET THE APP";

And a.wa will eventually only evaluate to true if you're on Chrome.
Component: General → Mobile
Product: Firefox for Android → Tech Evangelism
Summary: Fennec is recognizing on Google Docs app → Fennec never given "Use the App" button if user has Google Docs installed
Whiteboard: [country-all][contactready][clientsniff]
Karl, I'm not sure if Google will fix this, but can we let them know? Also, feel free to close this bug and reopen the webcompat one--I thought this might be a Gecko issue.
Flags: needinfo?(kdubost)
Sent an explanation to Google. Let's cross fingers.
Thanks mike and swarnava
Flags: needinfo?(kdubost)
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
> Thanks for the report. I've forwarded your message along to 
> the Google Docs team and will let you know what I hear back.
Whiteboard: [country-all][contactready][clientsniff] → [country-all][sitewait][clientsniff]
> This is now being tracked by internal issue 23211607, for future reference.
Swarnava, does it still reproduce?
Flags: needinfo?(swarnavasengupta)
I can still reproduce this issue on latest Firefox Beta + Samsung Galaxy S4 i9500 running Android 5.1.1
Flags: needinfo?(swarnavasengupta)
Thanks Swarnava. 
I  sent a reminder to Google.
Google's response: 

> The Docs team is tracking this issue, 
> but unfortunately usage from Firefox Android 
> is low so it might take a while for this bug to be prioritized.
And then today someone from the Google Docs team!

> I checked in a fix. It should hit production in a couple weeks.

Excellent thanks to him.
platform-rel: --- → ?
Whiteboard: [country-all][sitewait][clientsniff] → [country-all][sitewait][clientsniff][platform-rel-Google][platform-rel-GoogleDocs]
platform-rel: ? → +
Hey Swarnava, does this still reproduce?
Flags: needinfo?(swarnavasengupta)
Looks like it's working now on. tested on latest Firefox Beta for Android.
Flags: needinfo?(swarnavasengupta)
Thanks Swarnava!
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.