Closed Bug 1193065 Opened 5 years ago Closed 4 years ago

[Dialer] Switching call log to Missed and back to All will show an empty call log.

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master affected)

VERIFIED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: NicholasN, Assigned: heycam)

References

()

Details

(Keywords: regression, Whiteboard: [2.5-Daily-Testing][Spark])

Attachments

(2 files)

Attached file logcat_calllog.txt
Description:
The user has one or more completed or outgoing calls, and no missed calls. When they select missed calls and return to all, there will be no calls in the list.


Repro Steps:
1) Update an Aries to 20150810142756
2) Open dialer and make or recieve a couple calls.
3) Go to call log and select Missed.
4) Switch back to All.


Actual:
Switching from Missed to All in call log erases the calls from the All list.


Expected:
Calls remain visible after switching from Missed to All.


Notes:

Environmental Variables:
Device: Aries 2.5
Build ID: 20150810142756
Gaia: fa89e03dc489e79baa0e74cb1d205260c7924caa
Gecko: cd45a38ded04
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0


Repro frequency: 5/5
See attached: video clip, logcat
Issue also occurs on Flame 2.5, but not on Flame 2.2

Flame 2.5

Actual:
Switching from Missed to All in call log erases the calls from the All list.

Environmental Variables:
Device: Aries 2.5
BuildID: 20150810142756
Gaia: fa89e03dc489e79baa0e74cb1d205260c7924caa
Gecko: cd45a38ded04
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Flame 2.2

Actual:

Calls remain visible after switching from Missed to All.

Environmental Variables:
Device: Flame 2.2
BuildID: 20150810032504
Gaia: 102f1299e9eafe3760e1deb44d556b5c4f36b5af
Gecko: da29b5af4232
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regression
Whiteboard: [2.5-Daily-Testing][Spark]
[Blocking Requested - why for this release]: Functional regression.
blocking-b2g: --- → 2.5?
Requesting a window.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: pcheng
Comms triage: Functional regression
blocking-b2g: 2.5? → 2.5+
mozilla-inbound regression window:

Last Working
Device: Flame
BuildID: 20150805045800
Gaia: 581de383687dc441a878d2c91a0167c6ec688fef
Gecko: 25af02694bad
Version: 42.0a1 (2.5 Master) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

First Broken
Device: Flame
BuildID: 20150805054358
Gaia: 581de383687dc441a878d2c91a0167c6ec688fef
Gecko: 685014edb54e
Version: 42.0a1 (2.5 Master) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=25af02694bad&tochange=685014edb54e

We're really unsure which changeset could have caused this issue. If anyone is able to please look at the pushlog and help on picking a culprit.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Peter suggests that it's likely caused by changes made in bug 1180118.
Blocks: 1180118
Cameron, can you take a look at this please? This might have been caused by the work done for bug 1180118.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
piwei, could you try applying the patches to Gecko that I just attached to bug 1192302 and see if that resolves the bug?
Flags: needinfo?(pcheng)
Marking as P2.
Priority: -- → P2
Naoki or No Jun, could you please help create a build with Gecko patch at comment 8? Thanks.
Flags: needinfo?(npark)
Flags: needinfo?(nhirata.bugzilla)
I'll work on it and let you know
Flags: needinfo?(npark)
Thank you No Jun. Adding qawanted for the task at comment 8.
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(nhirata.bugzilla)
Keywords: qawanted
The issue persists with Gecko patches from bug 1192302 applied (build from comment 12). Switching to missed tab and back shows an empty call log.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pcheng)
Flags: needinfo?(jmercado)
Flags: needinfo?(cam)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Thanks for testing, No-Jun and Pi Wei.

I can reproduce this locally.
Assignee: nobody → cam
Status: NEW → ASSIGNED
Flags: needinfo?(cam)
The patches I just pushed to try in bug 1202512 comment 4 fix this issue.
Shall we dupe this against bug 1202512?
Flags: needinfo?(cam)
(In reply to Gabriele Svelto [:gsvelto] from comment #18)
> Shall we dupe this against bug 1202512?

Up to you.  I didn't want to tread on the B2G-specific tracking flags etc. by changing this bug's component.
Flags: needinfo?(cam)
I hand't noticed this had been marked as a blocker, I'll leave it as-is then and close it once you've landed the fix for the dependent bug. Thanks.
I've retested this today with the fix for bug 1202512 applied and the problem has been solved, closing.
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Verifying. Cannot reproduce with 2.5 Aries build:
Build ID: 20151018190150
Gaia:f75ae701
Version:44.0a1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.