Closed Bug 1193085 Opened 4 years ago Closed 4 years ago

[e10s] Tab audio indicator is still shown after navigating from audio-playing page loaded in a remote page to one in a non-remote page

Categories

(Firefox :: Tabbed Browser, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 43
Tracking Status
e10s m8+ ---
firefox41 --- unaffected
firefox42 --- unaffected
firefox43 --- verified

People

(Reporter: cpeterson, Assigned: ehsan)

References

()

Details

Attachments

(1 file)

STR:
1. Ensure e10s is enabled.
2. Load http://zombo.com/ (which uses Flash) or http://html5zombo.com/
3. Yeah! It works. Notice the tab's audio indicator icon.
4. In the zombo.com tab, load about:config (or any about: page other than about:blank).

RESULT:
about:config loads, but the audio indicator icon is still shown! This only happens when e10s is enabled.
Assignee: nobody → ehsan
This happens because about:config (or about: for that matter) are loaded as non-remote browsers.
Summary: [e10s] Tab audio indicator is still shown after navigating from audio-playing page to about:config → [e10s] Tab audio indicator is still shown after navigating from audio-playing page loaded in a remote page to one in a non-remote page
This problem also happens when going to reader mode (because that is rendered as about:reader?url=$URL.)
Marking 42 as unaffected sine we won't ship e10s in 42.
https://hg.mozilla.org/mozilla-central/rev/aaf23721afe9
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43
I've tested using latest Nightly 43.0a1 (buildID: 20150818030209) and I have the following scenario:
- go to http://html5zombo.com/ (the indicator is correctly displayed) -> Mute the tab -> go to about:config (or any about: page other than about:blank) => the audio indicator icon is still shown (if I mute the tab before loading the about: page). 

Any thoughts about this? Should I reopen this bug?
Flags: needinfo?(ehsan)
(In reply to Camelia Badau, QA [:cbadau] from comment #7)
> I've tested using latest Nightly 43.0a1 (buildID: 20150818030209) and I have
> the following scenario:
> - go to http://html5zombo.com/ (the indicator is correctly displayed) ->
> Mute the tab -> go to about:config (or any about: page other than
> about:blank) => the audio indicator icon is still shown (if I mute the tab
> before loading the about: page). 
> 
> Any thoughts about this? Should I reopen this bug?

No, that is the expected behavior.  The muted state on a tab is preserved across navigations.
Flags: needinfo?(ehsan)
Thanks for your answer!
Status: RESOLVED → VERIFIED
Depends on: 1214624
You need to log in before you can comment on or make changes to this bug.