tabbrowser.getTabForBrowser is not a function (Addon SDK pagemod not attaching content scripts)

RESOLVED DUPLICATE of bug 1149775

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 1149775
2 years ago
2 years ago

People

(Reporter: Kestrel, Unassigned)

Tracking

({addon-compat, regression})

Trunk
addon-compat, regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: parity-firefox)

User Story

tabbrowser: implement method getTabForBrowser() like Firefox
(Reporter)

Description

2 years ago
Versions affected: SeaMonkey 2.36a1-2.39a1 trunk

Extensions affected: Ghostery, Drag-Select Link Text and others.

sdk/page-mod is not loading content scripts, the page is not being affected by the script and the script does not appear in the remote debugger.

Attaching to existing pages results in error:

"tabbrowser.getTabForBrowser is not a function"

Excluding "attachTo" does not produce an error message but still the script is not loaded.

Updated

2 years ago
User Story: (updated)
Keywords: addon-compat
Summary: Addon SDK pagemod not attaching content scripts → tabbrowser.getTabForBrowser is not a function (Addon SDK pagemod not attaching content scripts)
Whiteboard: parity-firefox
(Reporter)

Comment 1

2 years ago
This was working in 2.32-2.35a2 so marking as a regression.
Keywords: regression

Updated

2 years ago
See Also: → bug 1039500

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1149775
You need to log in before you can comment on or make changes to this bug.