Closed Bug 1193354 Opened 7 years ago Closed 7 years ago

play.google.com - No image appearing on Firefox for Android

Categories

(Web Compatibility :: Mobile, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: hridoy43, Unassigned)

References

()

Details

(Keywords: site-compat, Whiteboard: [country-all] [sitewait])

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150709163524

Steps to reproduce:

1. Go to - Play.google.com
2. Wait until the page fully loaded.

(version 43.0a1)


Actual results:

No image appearing on the home page even on the other pages.


Expected results:

Images will appear.
Component: General → Mobile
Product: Firefox for Android → Tech Evangelism
I am able to reproduce this.
On Chrome will display them well.
Status: UNCONFIRMED → NEW
Ever confirmed: true
It seems that it works on 40 Beta 10 and doesn't in Aurora (42)
QA Whiteboard: testday-20150811
QA Whiteboard: testday-20150811
Component: Mobile → General
Product: Tech Evangelism → Firefox for Android
Attached file logs
All I see in this log is some deprecations
Snorp, any ideas?
Flags: needinfo?(snorp)
I have just debugged the page on Firefox Nightly for Android. The answer? They send WebP images ;)

On desktop:
https://lh3.googleusercontent.com/xBjI-GGSKVcuNslNIFj6qJBSaMC38B9EsNfbyxc1kBE1Z33P68YCRQsmSUOKOADI81w=w170

On Android:
https://lh3.googleusercontent.com/xBjI-GGSKVcuNslNIFj6qJBSaMC38B9EsNfbyxc1kBE1Z33P68YCRQsmSUOKOADI81w=w170-rw
Component: General → Mobile
Flags: needinfo?(snorp)
Keywords: site-compat
Product: Firefox for Android → Tech Evangelism
Version: Firefox 43 → unspecified
Depends on: 856375
Does "image/webp" appear in the accept header?
Firefox is sending the following Accept header:

> Accept:"image/png,image/*;q=0.8,*/*;q=0.5"
Looks like this was due to a change in the user-agent string format from Firefox mobile 41.0 onwards: https://developer.mozilla.org/en-US/docs/Web/HTTP/Gecko_user_agent_string_reference#Android_(version_40_and_below)

This has now been fixed on play.google.com and should be in effect soon. Sorry for the trouble and thanks for the report!
Blocks: 1169772
I think Firefox should change the Accept value string for image requests to explicitly state no support for WebP to avoid any similar future problems until the support is implemented, like this:

> Accept: image/png,image/*;q=0.8,*/*;q=0.5,image/webp;q=0
>                                          ^^^^^^^^^^^^^^^

By the way, what is `*/*;q=0.5` doing there?

I also had a problem with my Web site. It uses server-side content negotiation. image/webp matches both image/* and */*.

Negotiating content based on the User-Agent string is just plain wrong. No one should be doing it.

I know I'm the minority here. :(
@urvang thanks a lot. 
Do you know roughly when it will be pushed on production servers?

Testing as of now.

No images
Mozilla/5.0 (Android 4.4.4; Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Images
Mozilla/5.0 (Android; Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Flags: needinfo?(urvang2005)
Summary: No image appearing on play.google.com → play.google.com - No image appearing on play.google.com
Whiteboard: [country-all] [contactready]
Whiteboard: [country-all] [contactready] → [country-all] [sitewait]
I think this should be live on Monday/Tuesday.
I'll test on Firefox mobile 41 beta and confirm once it's live.
Flags: needinfo?(urvang2005)
Summary: play.google.com - No image appearing on play.google.com → play.google.com - No image appearing on Firefox for Android
Images look OK on Firefox on Android beta (version 41.0) now.
Working!
Thanks everyone. 
Thanks for the quick fix Urvang.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.