Crash when closing last tab

RESOLVED FIXED

Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: rnewman, Assigned: sleroux)

Tracking

({crash, reproducible})

unspecified
All
iOS
crash, reproducible

Firefox Tracking Flags

(fxios+)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
2015-08-11 13:33:52.873 Client[71458:3097656] *** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: 'An instance 0x7f832e07fa90 of class WKScrollView was deallocated while key value observers were still registered with it. Current observation info: <NSKeyValueObservationInfo 0x7f832be15320> (
<NSKeyValueObservance 0x7f832be153d0: Observer: 0x7f832becc9b0, Key path: contentSize, Options: <New: YES, Old: NO, Prior: NO> Context: 0x0, Property: 0x7f832be152f0>
)'
*** First throw call stack:
(
	0   CoreFoundation                      0x00000001060c3c65 __exceptionPreprocess + 165
	1   libobjc.A.dylib                     0x00000001055ebbb7 objc_exception_throw + 45
	2   CoreFoundation                      0x00000001060c3b9d +[NSException raise:format:] + 205
	3   Foundation                          0x00000001051c7332 NSKVODeallocate + 317
	4   CoreFoundation                      0x0000000105f998eb CFRelease + 603
	5   WebKit                              0x000000010811a671 _ZN3WTF9RetainPtrI12WKScrollViewED2Ev + 17
	6   WebKit                              0x0000000108115ef3 -[WKWebView .cxx_destruct] + 130
	7   libobjc.A.dylib                     0x00000001055ea448 _ZL27object_cxxDestructFromClassP11objc_objectP10objc_class + 127
	8   libobjc.A.dylib                     0x00000001055f89b1 objc_destructInstance + 96
	9   libobjc.A.dylib                     0x00000001055f89e4 object_dispose + 22
	10  UIKit                               0x0000000106f1df4a -[UIResponder dealloc] + 90
	11  UIKit                               0x0000000106dff3f4 -[UIView dealloc] + 992
	12  WebKit                              0x0000000108110fbd -[WKWebView dealloc] + 315
	13  CoreFoundation                      0x0000000105f998eb CFRelease + 603
	14  CoreFoundation                      0x0000000105fad21d -[__NSArrayM dealloc] + 157
	15  libobjc.A.dylib                     0x000000010560028e _ZN11objc_object17sidetable_releaseEb + 236
	16  libobjc.A.dylib                     0x00000001056008cd _ZN12_GLOBAL__N_119AutoreleasePoolPage3popEPv + 591
	17  CoreFoundation                      0x0000000105fb8f06 _CFAutoreleasePoolPop + 22
	18  CoreFoundation                      0x0000000105fecdd3 __CFRunLoopRun + 2051
	19  CoreFoundation                      0x0000000105fec366 CFRunLoopRunSpecific + 470
	20  GraphicsServices                    0x000000010a07ba3e GSEventRunModal + 161
	21  UIKit                               0x0000000106d9a8c0 UIApplicationMain + 1282
	22  Client                              0x000000010392aa47 main + 1047
	23  libdyld.dylib                       0x0000000108d41145 start + 1
	24  ???                                 0x0000000000000001 0x0 + 1
)
libc++abi.dylib: terminating with uncaught exception of type NSException
(Reporter)

Comment 1

3 years ago
1. Open m.canadacomputers.com
2. Observe that tab counter is 0
3. Close the tab
4. Crash
(Reporter)

Comment 2

3 years ago
Also happens if you open more tabs. Second tab bumps the count from 0 to 2. On closing the last tab, we crash.
tracking-fxios: --- → +
Keywords: reproducible
Summary: Crash when closing tab → Crash when closing last tab
(Assignee)

Updated

3 years ago
Assignee: nobody → sleroux
(Assignee)

Comment 3

3 years ago
Looks like this was introduced when I added the KVO observer from BrowserScrollController - will fix.
(Reporter)

Updated

3 years ago
Attachment #8646571 - Flags: review?(rnewman) → review+
(Reporter)

Updated

3 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 5

3 years ago
I merged this.

0e839ed
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.