Timezone change is not reflected in the status bar until reboot

RESOLVED FIXED

Status

Firefox OS
Gaia::System::Status bar, Utility tray, Notification
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: michal, Unassigned)

Tracking

({foxfood})

Firefox Tracking Flags

(Not tracked)

Details

>> Feature Request Summary:
Timezone change is not reflected in the status bar until reboot

>> Description of feature, or problem to be solved
When I changed the time zone from CEST to PDT the time shown in the status bar didn't change. It changed in the "Time" field under settings / date & time, though.

Rebooting the phone fixed it (for a short while the phone was showing 06:40 as if it was AM, changing to 18:40 after unlocking).
This is an expected regression per https://groups.google.com/d/msg/mozilla.dev.gaia/qgcEgxHonm8/8p0iy8hlGrwJ.  However, I'm not sure what bug to dupe this to.  Bug 1172699 I guess is what actually caused the regression, so duping to it seems wrong.  And bug 1172609 that I guess will fix this does not have a bug like this blocking it.

So... moving to the statusbar component (this component is for the clock app only and the clock app does not make the statusbar thing happen) and cc'ing relevant peoples.
Component: Gaia::Clock → Gaia::System::Status bar, Utility tray, Notification
yup, waiting for bug 1172609 - the patches are there, waiting for review now!
Depends on: 1172609
This should not be reproducible anymore. If you see it again, reopen the bug.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.