Clicking on link with IDN does not resolve properly

RESOLVED DUPLICATE of bug 309671

Status

()

Core
Networking
RESOLVED DUPLICATE of bug 309671
3 years ago
3 years ago

People

(Reporter: Abner Qian, Unassigned)

Tracking

40 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150807085045

Steps to reproduce:

Click on this link http://・ω・.blargel.com


Actual results:

The following message appears:

Server not found
Firefox can't find the server at %e3%83%bb%cf%89%e3%83%bb.blargel.com.

Firefox appears to encoding the IDN subdomain strangely before trying to resolve it.


Expected results:

Firefox should convert the subdomain into punycode instead of whatever it's doing above so that it resolves properly and the page loads.
(Reporter)

Comment 1

3 years ago
Hmm strange... It works if you click on the link from here. It definitely fails if you try to click on the face in the README on this git repo. https://github.com/Blargel/shopoon
(Reporter)

Updated

3 years ago
Blocks: 237820
(Reporter)

Comment 2

3 years ago
This actually seems like an issue with how Github is rendering the link. Regardless, Chrome handles this case perfectly fine.
Gijs, any idea who would know about an issue like this?

It seems like Firefox is able to navigate to an IDN host if a link uses the "pretty" version:

<a href="http://・ω・.blargel.com/">

but it fails if the link uses the encoded version:

<a href="http://%e3%83%bb%cf%89%e3%83%bb.blargel.com/">

Chrome Canary is able to navigate via either form of the link.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(gijskruitbosch+bugs)

Comment 4

3 years ago
Valentin or Anne van Kesteren.
Flags: needinfo?(valentin.gosu)
Flags: needinfo?(gijskruitbosch+bugs)
Flags: needinfo?(annevk)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(valentin.gosu)
Flags: needinfo?(annevk)
Resolution: --- → DUPLICATE
Duplicate of bug: 309671
Component: Untriaged → Networking
Product: Firefox → Core
You need to log in before you can comment on or make changes to this bug.