Closed Bug 1193695 Opened 4 years ago Closed 3 years ago

remove obsolete preference "gfx.prefer-mesa-llvmpipe" (and close related bugs to avoid confusion)

Categories

(Core :: Graphics, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla53
Tracking Status
firefox53 --- fixed

People

(Reporter: Ismail.Khoffi, Assigned: milan)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0
Build ID: 20150624141335

Steps to reproduce:

The preference "gfx.prefer-mesa-llvmpipe" is never used. 
It was introduced with bug 731836 but the code which made use of it was removed with bug 958368.
Currently the only occurence of  "gfx.prefer-mesa-llvmpipe" is in source/modules/libpref/init/all.js in line 699 (see http://lxr.mozilla.org/mozilla-aurora/source/modules/libpref/init/all.js#699 or grep/search for it yourself).


Actual results:

The preference has no impact and gives the user the impression, that he/she can influence firefox to use llvmpipe by setting it to true (which was the case but is'n anymore since bug 958368 was closed).


Expected results:

Either remove "gfx.prefer-mesa-llvmpipe" or reintroduce the code (see bug 958368) that uses this pref. 
In the first case some bugs should be closed/reopened to avoid confusion: bug 731983 (I would love to work on this addon btw), bug 958368, 731836

(Additionally I would be very glad, if someone could clarify how to officially (?) force firefox/ANGLE to use software-rendering as a fallback. I've managed to do so by (re)placing a dll (in the appropriate dir) and setting "webgl.disable-angle" and "webgl.force-enabled" to true. But this is out of the scope of this bug, I think? Thanks, though.)
Component: Untriaged → Preferences
Depends on: 731836, 958368
OS: Unspecified → All
Hardware: Unspecified → All
Version: 31 Branch → Trunk
Depends on: 731983
Component: Preferences → Graphics
Product: Firefox → Core
Comment on attachment 8811856 [details]
Bug 1193695: Removed unused preference.

https://reviewboard.mozilla.org/r/93778/#review93932
Attachment #8811856 - Flags: review?(lsalzman) → review+
Assignee: nobody → milan
Pushed by msreckovic@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9812afab78b2
Removed unused preference. r=lsalzman
https://hg.mozilla.org/mozilla-central/rev/9812afab78b2
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
You need to log in before you can comment on or make changes to this bug.