[Regression] Transition to URL edit mode stretches url label

RESOLVED FIXED

Status

()

Firefox for iOS
Theme & Visual Design
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: darrin, Assigned: sleroux)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios+)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Created attachment 8646928 [details]
stretchy-url.mov

See attached video. This looks pretty bad.
Expected: slide; no stretch, no scale.
(Assignee)

Comment 2

3 years ago
I'll see if this can be a quick win
WAIT whoa i think my fix fixes this too

Updated

3 years ago
Assignee: nobody → bmunar
Created attachment 8647101 [details] [review]
PR
Attachment #8647101 - Flags: ui-review?(dhenein)
Attachment #8647101 - Flags: review?(bnicholson)

Updated

3 years ago
Attachment #8647101 - Flags: review?(sleroux)
Comment on attachment 8647101 [details] [review]
PR

Haven't tried this out yet, but left some comments in the PR.
Attachment #8647101 - Flags: review?(bnicholson) → feedback+
(Assignee)

Comment 6

3 years ago
Comment on attachment 8647101 [details] [review]
PR

I don't think this fixes the stretching of the URL text or the alpha fade. 

Whenever we enter editing mode, the text looks to be stretched and the buttons disappear instead of animations out to the left.

Whenever we exit editing mode, the buttons appear right away on top of the text field

These were taking in landscape on the iPhone 6 simulator.

I'm not sure what the best approach is given we want to do an RC on Friday. I feel like modifying a bunch of the constraints might be risky. Let's have a discussion about this tomorrow @ triage.
Attachment #8647101 - Flags: review?(sleroux) → review-
(Assignee)

Comment 7

3 years ago
Created attachment 8647224 [details]
Enter editing
(Assignee)

Comment 8

3 years ago
Created attachment 8647226 [details]
Exiting editing
(Assignee)

Updated

3 years ago
Attachment #8647226 - Attachment description: Editing editing → Exiting editing
(Reporter)

Comment 9

3 years ago
Comment on attachment 8647101 [details] [review]
PR

This is the same patch as https://bugzilla.mozilla.org/show_bug.cgi?id=1190999 so same comments apply.
Attachment #8647101 - Flags: ui-review?(dhenein) → ui-review-

Updated

3 years ago
Assignee: bmunar → administration
(Assignee)

Updated

3 years ago
Assignee: administration → sleroux
Status: NEW → ASSIGNED
tracking-fxios: ? → +
(Assignee)

Updated

3 years ago
Attachment #8647101 - Attachment is obsolete: true
(Reporter)

Comment 11

3 years ago
Comment on attachment 8649380 [details] [review]
https://github.com/mozilla/firefox-ios/pull/948

Now we're talkin'! Looks great, thanks.
Attachment #8649380 - Flags: ui-review?(dhenein) → ui-review+
Attachment #8649380 - Flags: review?(bnicholson) → review+
(Assignee)

Comment 12

3 years ago
I found an issue with the text stretch PR - because I moved the setting of the text inside the dispatch_async method, there was a bug where when you switch tabs, and you go to edit the url, you see the old url for a moment before the new one comes in. Added an update for it here so we can preserve the same behaviour for the pasted case: https://github.com/mozilla/firefox-ios/commit/ac06df4fa486fe5ee304465ad670c873a45dd782
(Assignee)

Comment 13

3 years ago
Merged
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.