Closed Bug 1193802 Opened 7 years ago Closed 6 years ago

Major graphics artefacts overlaying text input in location bar on Intel GPU

Categories

(Core :: Graphics, defect)

40 Branch
x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
firefox40 + fixed

People

(Reporter: philipp, Assigned: jrmuizel)

References

Details

(Whiteboard: [gfx-noted])

something that sounds very similar to bug 1180379 has been reported by a user on the sumo forums: https://support.mozilla.org/en-US/questions/1077252

he has a newer intel gpu than in the originally reported bug, but an old driver as well:

Graphics
Adapter Description	Intel(R) HD Graphics Family
Adapter Drivers	igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
Adapter RAM	Unknown
Asynchronous Pan/Zoom	none
Device ID	0x0106
Direct2D Enabled	true
DirectWrite Enabled	true (6.2.9200.17292)
Driver Date	4-4-2011
Driver Version	8.15.10.2353
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 11 (OMTC)
Subsys ID	00000000
Supports Hardware H264 Decoding	true
Vendor ID	0x8086
WebGL Renderer	Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d 1.1
AzureContentBackend	direct2d 1.1
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
(#0) Error	OpenSharedResource failed for format 65
Please have this person update their graphics driver and report back. Let's not call this a regression until we've exhausted all troubleshooting steps and have reliable steps to reproduce. Thanks.
Severity: major → normal
Keywords: regression
Whiteboard: [gfx-noted]
Showing up in input as well:

  "graphics":{
    "adapterDescription":"Intel(R) HD Graphics Family",
    "adapterDescription2":"",
    "adapterDeviceID":"0x0116",
    "adapterDeviceID2":"",
    "adapterDrivers":"igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32",
    "adapterDrivers2":"",
    "adapterRAM":"Unknown",
    "adapterRAM2":"",
    "adapterSubsysID":"00000000",
    "adapterSubsysID2":"",
    "adapterVendorID":"0x8086",
    "adapterVendorID2":"",
    "direct2DEnabled":true,
    "directWriteEnabled":true,
    "directWriteVersion":"6.2.9200.17461",
    "driverDate":"4-4-2011",
    "driverDate2":"",
    "driverVersion":"8.15.10.2353",
    "driverVersion2":"",
    "failures":[
      "[GFX1-]: OpenSharedResource failed for format 65"

Possibly just older graphics drivers, in which case we may want to blocklist.
about:support data from another presumably affected users at https://support.mozilla.org/en-US/questions/1077541

Graphics

Adapter Description: Intel(R) HD Graphics Family
Adapter Drivers: igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
Adapter RAM: Unknown
Asynchronous Pan/Zoom: none
Device ID: 0x0116
Direct2D Enabled: true
DirectWrite Enabled: true (6.2.9200.17461)
Driver Date: 3-25-2011
Driver Version: 8.15.10.2342
GPU #2 Active: false
GPU Accelerated Windows: 2/2 Direct3D 11 (OMTC)
Subsys ID: 397517aa
Supports Hardware H264 Decoding: true
Vendor ID: 0x8086
WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
(#0) Error: OpenSharedResource failed for format 65
(#1) Error: [D2D1.1] Attempt to use unsupported surface size Size(1191,9020)
(#2) Error: Failed to create DrawTarget, Type: 7 Size: Size(1191,9020)
(#3) Error: [D2D1.1] Attempt to use unsupported surface size Size(1191,10658)
(#4) Error: Failed to create DrawTarget, Type: 7 Size: Size(1191,10658)

& two more comments from input: 
https://input.mozilla.org/dashboard/response/5547666
https://input.mozilla.org/dashboard/response/5547307
Ok, we'll try to reproduce this locally
Side note - the failure message suggests we will skip hardware video decoding and take a different path in WebGL - nothing in the comments suggests either of those as a part of the workflow, so this is either irrelevant, or caused by the same underlying problem.
Any additional about:support's that you can collect would be very helpful
Seems like an important issue. Tracking!
Here's the GPU info of 4 Input users (Tyler already included one of these).  I'll add more users to the sheet upon finding new comments.  Thanks

https://docs.google.com/spreadsheets/d/1Sww78sFe2VwDPB4g37eupbyMKTZNTnM1f6ocoQ1O6wk/edit#gid=0

Looks like it's all the same GPU family as suspected.
I can reproduce the issue locally with the 2342 driver. Updating the driver using Windows Update moves me to 9.17.10.2843 which no longer has the issue.
(In reply to Jeff Muizelaar [:jrmuizel] from comment #6)
> Any additional about:support's that you can collect would be very helpful

if it's alright i will only post new data from sumo, if the adapter/driver version deviates from the ones we already know or if you want me to stop :-)

this is a newish one (but captured while hwa was off for testing purposes):

Adapter Description: Intel(R) HD Graphics
Adapter Drivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
Adapter RAM: Unknown
Asynchronous Pan/Zoom: none
Device ID: 0x0046
DirectWrite Enabled: false (6.2.9200.17461)
Driver Date: 6-3-2011
Driver Version: 8.15.10.2413
GPU #2 Active: false
GPU Accelerated Windows: 0/1 Basic (OMTC)
Subsys ID: 7008103c
Supports Hardware H264 Decoding: false
Vendor ID: 0x8086
WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: true
AzureCanvasBackend: skia
AzureContentBackend: cairo
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
(#0) Error: OpenSharedResource failed for format 65

https://support.mozilla.org/en-US/questions/1077252#answer-767340
Jorge can you add the following to the blocklist?

<gfxBlacklistEntry>
  <os>All</os>
  <vendor>0x8086</vendor>
  <feature>DIRECT2D</feature>
  <featureStatus>BLOCKED_DRIVER_VERSION</featureStatus>
  <driverVersion>8.15.10.2361</driverVersion>
  <driverVersionComparator>LESS_THAN</driverVersionComparator>
</gfxBlacklistEntry>
Flags: needinfo?(jorge)
(In reply to philipp from comment #10)
> (In reply to Jeff Muizelaar [:jrmuizel] from comment #6)
> > Any additional about:support's that you can collect would be very helpful
> 
> if it's alright i will only post new data from sumo, if the adapter/driver
> version deviates from the ones we already know or if you want me to stop :-)

This is very valuable, please continue.
the last one from comment #10 would slip through this gfxBlacklistEntry ?
Flags: needinfo?(jmuizelaar)
Yes it would, maybe to be safe we should go with:

<gfxBlacklistEntry>
  <os>All</os>
  <vendor>0x8086</vendor>
  <feature>DIRECT2D</feature>
  <featureStatus>BLOCKED_DRIVER_VERSION</featureStatus>
  <driverVersion>8.15.10.2413</driverVersion>
  <driverVersionComparator>LESS_THAN_OR_EQUAL</driverVersionComparator>
</gfxBlacklistEntry>
Flags: needinfo?(jmuizelaar)
Adapter Description: Intel(R) HD Graphics
Adapter Drivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
Adapter RAM: Unknown
Asynchronous Pan/Zoom: none
ClearType Parameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 400
Device ID: 0x0042
Direct2D Enabled: true
DirectWrite Enabled: true (6.2.9200.17461)
Driver Date: 8-25-2010
Driver Version: 8.15.10.2202
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Subsys ID: 04381028
Supports Hardware H264 Decoding: true
Vendor ID: 0x8086
WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
(#0) Error: OpenSharedResource failed for format 65

https://support.mozilla.org/en-US/questions/1077906
The blocklist entry has been added per comment #14.
Flags: needinfo?(jorge)
I can reproduce this on 8.15.10.2413 but not on 8.15.10.2401 :(
I could also not reproduce this on 8.15.10.2418 FWIW
This looks a lot like bug 1180379, where we blocklisted all of GMAX4500 devices.
Assignee: nobody → jmuizelaar
Flags: needinfo?(jmuizelaar)
Flags: needinfo?(bas)
Yes, I believe it's the same bug. The reason we blacklisted all of the GMAX4500 devices is because they don't have a driver new enough to have a fix.
Flags: needinfo?(jmuizelaar)
Flags: needinfo?(bas)
Marked as fixed for 40 as we blocklisted it (yeh, I know it is not a proper fix).
Duplicate of this bug: 1196025
Assuming fixed since no one has chimed in on this bug in a few months. Please reopen if this is still an issue.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
New problèm... W7 Firefox 42 https://forums.mozfr.org/viewtopic.php?f=5&t=126760&start=15#p806060

Accélération graphique
Date du pilote 8-4-2015
Description de la carte Intel(R) HD Graphics 4400
Direct2D activé true
DirectWrite activé true (6.2.9200.17461)
Fenêtres avec accélération graphique 2/2 Direct3D 11 (OMTC)
GPU 2 actif false
ID du périphérique 0x041e
ID du sous-système 00000000
ID du vendeur 0x8086
Pilotes de la carte igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
Prise en charge matérielle pour le décodage H264 true
RAM de la carte Unknown
Rendu WebGL Google Inc. -- ANGLE (Intel(R) HD Graphics 4400 Direct3D11 vs_5_0 ps_5_0)
Version du pilote 10.18.14.4264
windowLayerManagerRemote true
Zoom/Panoramique asynchrones aucun
AzureCanvasBackend direct2d 1.1
AzureContentBackend direct2d 1.1
AzureFallbackCanvasBackend cairo
AzureSkiaAccelerated 0
(#0) Error [D2D1.1] Attempt to use unsupported surface size Size(1349,28519)
(#7) Error Failed to create DrawTarget, Type: 7 Size: Size(1349,20064)
(#8) Error [D2D1.1] Attempt to use unsupported surface size Size(1349,20279)
(#9) Error Failed to create DrawTarget, Type: 7 Size: Size(1349,20279)
(#10) Error [D2D1.1] Attempt to use unsupported surface size Size(1349,29679)
(#11) Error Failed to create DrawTarget, Type: 7 Size: Size(1349,29679)
This is a report from a different graphics card - Intel HD Graphics 4600, not part of the ones that we blocked, with a fairly new driver.  Likely worth a separate bug.  Anthony, could you make a new bug for it and we can take it from there?
Flags: needinfo?(anthony.s.hughes)
(In reply to Bob49 from comment #26)
> New problèm... W7 Firefox 42
> https://forums.mozfr.org/viewtopic.php?f=5&t=126760&start=15#p806060

How is this issue related? It seems to be about a Shockwave plugin not responding and not a graphics rendering issue. Bob, I would appreciate it if you could file a new bug report as you'll be able to provide context which I just do not have.
Flags: needinfo?(anthony.s.hughes)
thank you to delete my previous post (and this one), because no news of the person who had the problem !!.. since disabling hardware acceleration Firefox ... So we must imagine that the problem is solved!!

sorry for the disarrangement
Better safe than sorry, thanks!
You need to log in before you can comment on or make changes to this bug.