Expose tab muting option more in the UI

RESOLVED DUPLICATE of bug 1193191

Status

()

RESOLVED DUPLICATE of bug 1193191
3 years ago
3 years ago

People

(Reporter: jaramat, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Current state: Users can mute a tab only if it's playing audio. Ultimately, most people probably don't even know they can do so until the speaker icon is shown on the tab.

Proposed change: Expose Tab Mute more in the UI. This can be done either by adding a menu item to the Edit menu (Edit -> Mute Tab/Unmute Tab), or adding a menu item to the tab context menu (right under the Reload Tab option).

Now, I know some people here complained that this would make the tab context menu "too long" or "too crowded". Consider this: maybe, in the future, when/if we decide to remake the tab context menu the same way the page context menu is (4 horizontally placed icons), we'll have more vertical space for more tab commands. Or, add Mute Tab to the horizontal row, so the icons would be: <Reload Tab>, <Un/Pin Tab>, <Un/Mute Tab>, <Close Tab>, and then the rest below them.

Comment 1

3 years ago
As https://bugzilla.mozilla.org/show_bug.cgi?id=1188860 was initially defined it was meant to only be an icon so I'm not sure if expanding that spec is desirable or in scope...
Blocks: 1188860
Flags: needinfo?(ehsan)

Comment 2

3 years ago
This is almost the same thing as what bug 1193191 asking for.  Exactly like that bug, it will not block us shipping this feature.  Duping against that bug.
No longer blocks: 1188860
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(ehsan)
Resolution: --- → DUPLICATE
Duplicate of bug: 1193191
You need to log in before you can comment on or make changes to this bug.