All users were logged out of Bugzilla on October 13th, 2018

[Download Manager]"Download Manager" fails to record download history.

VERIFIED FIXED

Status

--
major
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: wangxin, Assigned: gandalf)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

Details

(Whiteboard: [2.5-aries-test-run-1])

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8647395 [details]
Bug log: logcat_1546.txt

[1.Description]:
[Aries v2.5][Flame v2.5][Download Manager]If user has never entered "Download Manager", the download info will not update to "Download Manager".
See video: "Aries_v2.5.3GP".
See log: "logcat_1546.txt"
Found Time: 15:46

[2.Testing Steps]: 
Precondition: "Download Manager" is not launched.
1. Download some files from Browser.
2. Launch "Settings"->"Downloads".

[3.Expected Result]: 
2. The download files in step1 should display in download list

[4.Actual Result]: 
2. You can see the download list is blank.

[5.Reproduction build]: 
Device: Flame KK 2.2 (Unaffected)
Build ID               20150812032504
Gaia Revision          102f1299e9eafe3760e1deb44d556b5c4f36b5af
Gaia Date              2015-08-06 20:46:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/9295034c0ee3
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150812.065135
Firmware Date          Wed Aug 12 06:51:47 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.5 (Affected)
Build ID               20150812150204
Gaia Revision          52f3ea58df38e5427f6afeb636bc6ad01d24022f
Gaia Date              2015-08-12 16:40:43
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cf932fc931dcd19f425934db79bec641ebe2a8a9
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150812.182303
Firmware Date          Wed Aug 12 18:23:12 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5(Affected)
Build ID               20150811234258
Gaia Revision          c7875bbc8b32e7b95cc55c9690b03b140905d84d
Gaia Date              2015-08-11 18:18:36
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d4f3a8a75577e4af2914a4e899ca2e724f9715c4
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150811.230622
Firmware Date          Tue Aug 11 23:06:29 UTC 2015
Bootloader             s1

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
13523
(Reporter)

Comment 1

3 years ago
Created attachment 8647396 [details]
Bug video: Aries_v2.5.3GP
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Keywords: regression
See Also: → bug 1180250
[Blocking Requested - why for this release]: the main function of Download can't work, and user can't check the downloaded files once the device is relaunched or Settings is killed. Nominate.
blocking-b2g: --- → 2.5?

Comment 3

3 years ago
Request a regression-window because it is a major bug.
Keywords: regressionwindow-wanted
See Also: bug 1180250
QA Contact: pcheng
central regression window:

Last Working
Device: Flame
BuildID: 20150808183811
Gaia: 0afa6429bf6a772289801600a84438cd7aa27b11
Gecko: fd63d8ed9d2e
Version: 42.0a1 (2.5 Master) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

First Broken
Device: Flame
BuildID: 20150808193811
Gaia: 3e5271663e7ef26290c29a45d2e42c0d3c20fe04
Gecko: 24f4d8e5e24b
Version: 42.0a1 (2.5 Master) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Last Working Gaia First Broken Gecko - no repro
Gaia: 0afa6429bf6a772289801600a84438cd7aa27b11
Gecko: 24f4d8e5e24b

Last Working Gecko First Broken Gaia - repro
Gaia: 3e5271663e7ef26290c29a45d2e42c0d3c20fe04
Gecko: fd63d8ed9d2e

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/0afa6429bf6a772289801600a84438cd7aa27b11...3e5271663e7ef26290c29a45d2e42c0d3c20fe04

Caused by changes made in Bug 1187668.
Blocks: 1187668
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Zibi, can you take a look at this please? This might have been caused by the landing for bug 1187668.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(gandalf)
(Assignee)

Comment 6

3 years ago
Taking
Assignee: nobody → gandalf
Flags: needinfo?(gandalf)
Triage: regression, broken functionality.
blocking-b2g: 2.5? → 2.5+
Created attachment 8649019 [details] [review]
[gaia] zbraniecki:1194127-readd-l10ndate-to-settings-for-downloads > mozilla-b2g:master
(Assignee)

Comment 9

3 years ago
Comment on attachment 8649019 [details] [review]
[gaia] zbraniecki:1194127-readd-l10ndate-to-settings-for-downloads > mozilla-b2g:master

That's sad :(

The reason for this regression is that we do use l10n_date in Downloads panel in Settings for prettyDate formatting.

The real solution is to extend the Intl API to handle relative dates and it's part of my proposal for the Intl API extension, but that's quite a bit far away from implementation.

So for now, we have to deal with the fact that prettyDate has to be handled by us manually. In order to facilitate that, I ported prettyDate to use async l10n API and updated the docstrings to indicate that prettyDate is deprecated.

Stas - can you look at this change to l10n_date.js?
Evelyn - apologies for the regression!
Attachment #8649019 - Flags: review?(stas)
Attachment #8649019 - Flags: review?(ehung)

Comment 10

3 years ago
Comment on attachment 8649019 [details] [review]
[gaia] zbraniecki:1194127-readd-l10ndate-to-settings-for-downloads > mozilla-b2g:master

It looks fine on Settings part. Thank you, Zibi!
Attachment #8649019 - Flags: review?(ehung) → review+
Comment on attachment 8649019 [details] [review]
[gaia] zbraniecki:1194127-readd-l10ndate-to-settings-for-downloads > mozilla-b2g:master

r=me, thanks.
Attachment #8649019 - Flags: review?(stas) → review+
(Assignee)

Comment 12

3 years ago
Commit: https://github.com/mozilla-b2g/gaia/commit/d9ae7f14b3d67afdeb06e859f93bc34c8158ce23
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 13

3 years ago
This bug has been verified as pass on latest Aries_v2.5 and Flame_v2.5,
STR:
Same STR with comment 0.
Repro rate: 0/10

Actural result:
The download files will display in download list

Device: Aries KK 2.5(Pass)
Build ID               20150820005800
Gaia Revision          89e0096a3de0378e3eda77e6a2a0bb5ca03eb8bb
Gaia Date              2015-08-19 18:28:14
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/29b2df16e961fbe9a379362ecba6f888d1754bc3
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150820.002839
Firmware Date          Thu Aug 20 00:28:46 UTC 2015
Bootloader             s1

Flame KK 2.5(Pass):
Build ID               20150819150203
Gaia Revision          8f77edf3ac39d36f6df0f5517223d3ed35ed89e0
Gaia Date              2015-08-19 11:28:39
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d590b9601ba8138b621b2553daefd8823ab4295a
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150819.202112
Firmware Date          Wed Aug 19 20:21:24 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
status-b2g-master: affected → verified
You need to log in before you can comment on or make changes to this bug.