[gui] add the ability to use addons

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: parkouss, Assigned: sabergeass, Mentored)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

49 bytes, text/x-github-pull-request
parkouss
: review+
parkouss
: feedback+
Details | Review | Splinter Review
(Reporter)

Description

3 years ago
This is equivalent to:

-e PATH1, --addon PATH1
                        addon to install; repeat for multiple addons.

command line option.

So, I think we should add in the Profile wizard page a list to be able to add/remove addons. This could looks like: http://doc.qt.io/qt-4.8/images/assistant-preferences-documentation.png

After this is done, we should pass the addon list (or None if there is none) to the Bisection - from memory, it should looks like the profile. The code in mozregression/main.py might help: https://github.com/mozilla/mozregression/blob/0bfa1b8df0d865e3641814a1aa6fefa7c0c11ff9/mozregression/main.py#L361.
(Assignee)

Comment 1

3 years ago
Created attachment 8649340 [details] [review]
PR for bug 1194219

Hmm, not sure about it. No error shows up, but when I test it locally, It seems like also found nothing to me. Just ask feedback for now, and I will keep diging it until I figure out the problem.
Attachment #8649340 - Flags: feedback?(j.parkouss)
(Reporter)

Comment 2

3 years ago
Comment on attachment 8649340 [details] [review]
PR for bug 1194219

It works for me with a simple fix:

diff --git a/gui/mozregui/bisection.py b/gui/mozregui/bisection.py
index 61ebc44..063b4e2 100644
--- a/gui/mozregui/bisection.py
+++ b/gui/mozregui/bisection.py
@@ -258,8 +258,7 @@ class BisectRunner(QObject):
                     launcher_kwargs[name] = value
 
         # add add-ons path to the app luncher
-        for path in options['addons']:
-            launcher_kwargs['addons'] = path
+        launcher_kwargs['addons'] = options['addons']
         self.bisector.test_runner.launcher_kwargs = launcher_kwargs
 
         self.thread.start()

I am able to run a process with an addon after that. :) This is just because launcher_kwargs['addons'] needs a list of string.

Also, I will make some comment on the PR, but otherwise this is good!
Attachment #8649340 - Flags: feedback?(j.parkouss) → feedback+
(Assignee)

Updated

3 years ago
Attachment #8649340 - Flags: review?(j.parkouss)
(Reporter)

Comment 3

3 years ago
Comment on attachment 8649340 [details] [review]
PR for bug 1194219

This is great!

Thanks MikeLing - I did not tested yet but I assume it works (will try it before merging). Have you tested it ?

I commented a few things on travis PR, just minor nits.

I'll be happy to merge this in after you fixed them!
Attachment #8649340 - Flags: review?(j.parkouss) → review+
(Assignee)

Comment 4

3 years ago
(In reply to Julien Pagès from comment #3)
> Comment on attachment 8649340 [details] [review]
> PR for bug 1194219
> 
> This is great!
> 
> Thanks MikeLing - I did not tested yet but I assume it works (will try it
> before merging). Have you tested it ?
> 
> I commented a few things on travis PR, just minor nits.
> 
> I'll be happy to merge this in after you fixed them!

Just test the PR and it works fine I think :)
(Reporter)

Comment 5

3 years ago
Thanks MikeLing for the work here!

Just merged this manually in https://github.com/mozilla/mozregression/commit/bd1110e2ee242450458663dd2a1c7e1155a89f7f.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.