Closed Bug 1194443 Opened 5 years ago Closed 5 years ago

First run of the browser should import from default browser

Categories

(Firefox :: Migration, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 737804

People

(Reporter: jaws, Unassigned)

References

(Blocks 1 open bug)

Details

The stub installer should import from the default browser into Firefox by default. 

I don't know if we would want/need a way to "undo" the import on first-run if the user is unhappy about it, but that could be something to look in to.
Component: Migration → Installer
Why should it be in the stub installer vs. the Firefox migration code where it currently is?
(In reply to Robert Strong [:rstrong] (use needinfo to contact me) from comment #1)
> Why should it be in the stub installer vs. the Firefox migration code where
> it currently is?

I saw this is done by the Opera stub installer. It could probably be migrated on first-run of the browser, but have the opt-out in the stub installer so that the first-run migration is interactionless.
So, adding another option to the options page of the stub installer so users can opt-out if they want? Most users don't click the options button and would never see this option to opt-out. Personally, I don't see much to any value in adding this.
Yeah, basically this would enable it for all users. I suppose if we had an "undo" for migration then we could leave the installer untouched. I'll tweak this bug.
Summary: Stub installer should import from default browser by default (opt-out in Options/Advanced) → First run of the browser should import from default browser
Component: Installer → Migration
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 737804
You need to log in before you can comment on or make changes to this bug.