Missing info about being offline (status 2152398864)

RESOLVED FIXED

Status

Other Applications
ChatZilla
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: scootergrisen, Assigned: Gijs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [cz-0.9.93])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:39.0) Gecko/20100101 Firefox/39.0 Iceweasel/39.0.3
Build ID: 20150807000803

Steps to reproduce:

Select offline mode in ChatZilla 0.9.92.
Close ChatZilla.
Now lets say we forget that we selected offline mode in ChatZilla.


Actual results:

Next time i click a IRC click, ChatZilla opens, but does not says the program is in offline mode.

Says stuff like connection close with status 2152398864... trying about in 15 seconds.
But it does not actually tell the user that the program is offline.

And the online/offline in the bottom right corner is easy to miss.


Expected results:

Tell the user that ChatZilla is offline, so the user knows why ChatZilla can't connect/join.
Created attachment 8648003 [details] [diff] [review]
Patch
Assignee: rginda → gijskruitbosch+bugs
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8648003 - Flags: review?(bugzilla-mozilla-20000923)
Created attachment 8648011 [details] [diff] [review]
Patch v2
Attachment #8648003 - Attachment is obsolete: true
Attachment #8648003 - Flags: review?(bugzilla-mozilla-20000923)
Attachment #8648011 - Flags: review?(bugzilla-mozilla-20000923)

Comment 3

3 years ago
Comment on attachment 8648011 [details] [diff] [review]
Patch v2

Review of attachment 8648011 [details] [diff] [review]:
-----------------------------------------------------------------

::: xul/content/handlers.js
@@ +2120,5 @@
>                  msg = MSG_PROXY_CONNECTION_REFUSED;
>                  break;
>  
> +            case NS_ERROR_OFFLINE:
> +                msg = MSG_ERR_OFFLINE;

Given the old code (below) uses MSG_CONNECTION_ABORT_OFFLINE, shouldn't we do the same thing here?
(In reply to James Ross from comment #3)
> Comment on attachment 8648011 [details] [diff] [review]
> Patch v2
> 
> Review of attachment 8648011 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: xul/content/handlers.js
> @@ +2120,5 @@
> >                  msg = MSG_PROXY_CONNECTION_REFUSED;
> >                  break;
> >  
> > +            case NS_ERROR_OFFLINE:
> > +                msg = MSG_ERR_OFFLINE;
> 
> Given the old code (below) uses MSG_CONNECTION_ABORT_OFFLINE, shouldn't we
> do the same thing here?

I avoided that because that case still gets hit when you go into offline mode while connecting/connected, and the language it uses ("The connection to ... was aborted because you *went into* offline mode." - emphasis mine) it seemed more appropriate to use this message (which we are already trying to use when attempting to doConnect, which apparently doesn't throw immediately anymore :-\

Comment 5

3 years ago
Comment on attachment 8648011 [details] [diff] [review]
Patch v2

Review of attachment 8648011 [details] [diff] [review]:
-----------------------------------------------------------------

We get different error codes through the same code path depending on if we're trying to connect in offline mode vs. changing to offline mode whilst connected? That sounds fantastic.

r+ if you're happy the right message is shown in each of the two cases, anyway.
Attachment #8648011 - Flags: review?(bugzilla-mozilla-20000923) → review+
remote:   https://hg.mozilla.org/chatzilla/rev/f6433a502976
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Whiteboard: [cz-0.9.93]
You need to log in before you can comment on or make changes to this bug.