avoid shift overflows in devtools server tests

RESOLVED DUPLICATE of bug 1198980

Status

DevTools
General
RESOLVED DUPLICATE of bug 1198980
3 years ago
9 days ago

People

(Reporter: froydnj, Assigned: froydnj)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Comment 1

3 years ago
Created attachment 8648376 [details] [diff] [review]
avoid shift overflows in devtools gtests

clang complains about shifting quantities beyond the width of their
type, since that is undefined behavior.  Let's fix the problematic
occurrences by adding some casts prior to shifting.
(Assignee)

Updated

3 years ago
Attachment #8648376 - Flags: review?(nfitzgerald)
Comment on attachment 8648376 [details] [diff] [review]
avoid shift overflows in devtools gtests

Review of attachment 8648376 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #8648376 - Flags: review?(nfitzgerald) → review+
(Assignee)

Comment 4

3 years ago
Backed out because the test was apparently depending on truncation of the values, or something?

https://hg.mozilla.org/integration/mozilla-inbound/rev/a30421f03bc5
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1198980

Updated

9 days ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.