Closed Bug 1195005 Opened 4 years ago Closed 3 years ago

There is no way to add a custom search engine or edit an existing one in about:preferences#search

Categories

(Firefox :: Preferences, defect)

defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: archil, Unassigned)

References

Details

It's been ages that other web browsers have the ability to add new custom search engines and/or edit existing ones. We the users need the ability to modify the list of search engines. We the users have strong reasons if you're asking why. Please, be kind and add the feature. Thank you!
Severity: normal → critical
Any updates?
Engines can be added either via OpenSearch discovery (you'll see a (+) badge above the glass icon of the search bar when a website offers OpenSearch engines) or from the add-ons website https://addons.mozilla.org/en-US/firefox/search-engines/
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
I know both ways and they have flaws:
* When using OpenSearch discovery a website owner adds parameters to a search query which cannot be removed or edited. Sometimes it contains small parameters like where the search has come from. Sometimes it contains even tokens that identify the search engine installation. Thus binding every search term to each other. Which is a privacy issue.
* On the addons website the search engine authors may add some parameters that I would like to remove or edit but this impossible. Some search engines like DuckDuckGo offer customization for which I would like to have a custom search engine by adding additional parameters. Thus I would about using cookies.

I'm sure you've seen Chrome's implementation of search engines. Which has only one flaw. At least one search engine has to exist, but that's okay as long as you can remove every search engine including Google Search.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
If you want to customize the parameters of a search plugin, the best way seems to be to create a new search plugin, edit the xml file, and install that.

If you only need to use the engines from keyboards in the url bar and don't need the engine to appear in the search bar, the bookmark keyword feature may do what you want. See https://support.mozilla.org/en-US/kb/how-search-from-address-bar (once the bookmark is saved, you can edit the URL from the bookmark manager).
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → WONTFIX
Summary: There is no way to add a custom search engine or edit an existing one → There is no way to edit the parameters sent by search engines
You cannot edit a built-in search engine by creating a search plugin. You cannot even give your newly created search engine a name that's already built-in. And to my opinion, adding or editing a search engine is so trivial that a user shouldn't have to write an XML file for that. It can be done via interface.

I don't recommend Chrome to anyone but I suggest you to see how easy it is to add, edit and delete search engines in that browser.

The bookmark keywords feature doesn't allow users set it as a default search engine. Thus rendering it useless in that case.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
Summary: There is no way to edit the parameters sent by search engines → There is no way to add a custom search engine or edit an existing one in about:preferences#search
(In reply to Archil Imnadze from comment #5)
> You cannot edit a built-in search engine by creating a search plugin.

I don't think we want to allow editing built-in engines.

> I don't recommend Chrome to anyone but I suggest you to see how easy it is
> to add, edit and delete search engines in that browser.

I tried the Chrome search preference UI. It's interesting, but too simple to allow editing our built-in or OpenSearch-discovered engines. For example, it doesn't support showing/editing the URL used to fetch suggestions. If the reason why you want to edit the engine URL is privacy, the URL used for suggestions is at least as important, as it's the URL that gets all your keystrokes.

Being able to set as the default an engine that has been created by just entering an URL or from an input field is nice though.

> The bookmark keywords feature doesn't allow users set it as a default search
> engine.

I think we would get this by merging the bookmark keyword feature and the list of search engines. This is covered by bug 648398. Do you agree this is a duplicate of bug 648398?
Bug 648398 seems to be a good idea but not really the same.

> I don't think we want to allow editing built-in engines.
Is there a way to create a search engine and name it "DuckDuckGo" and which would not be the same as built-in search engine of the same name. If so we can close this bug.
Severity: critical → normal
Blocks: 782599
Component: Search → Preferences
While creating a search new engine can be an alternative to editing an existing one, it is only viable when the user can use an already installed engine as a reference, even if they do not have access to the original engine XML or to any web site.

An acceptable sequence of operations will be:
1. Export an existing search engine to a local XML file
2. Edit the file
3. Install the local file as a new search engine.
> 2. Edit the file
> 3. Install the local file as a new search engine.
Will I be able to name the search engine as "DuckDuckGo"?
(In reply to bugzilla1 from comment #8)
> While creating a search new engine can be an alternative to editing an
> existing one, it is only viable when the user can use an already installed
> engine as a reference, even if they do not have access to the original
> engine XML or to any web site.
> 
> An acceptable sequence of operations will be:
> 1. Export an existing search engine to a local XML file
> 2. Edit the file
> 3. Install the local file as a new search engine.

I did an add-on to support this specific use case:
https://addons.mozilla.org/en-US/firefox/addon/search-engines-export-import/
Man, this bug is not for importing/exporting search engines. It's for editing the existing ones. It's our right to change URLs or add/remove additional parameters to the search engines.
+1
Why is it so hard for Mozilla to see the obvious?

Just look at Opera, Vivaldi and Chrome. You can customize, add and remove search engines in a blink of eyes. For more than a decade.

In Firefox, however, search engines management is a pain.
****, I no longer care.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.