Fennec nightly fails to install updates

RESOLVED DUPLICATE of bug 1194741

Status

()

RESOLVED DUPLICATE of bug 1194741
4 years ago
4 years ago

People

(Reporter: kats, Unassigned)

Tracking

Trunk
All
Android
Points:
---

Firefox Tracking Flags

(firefox43 affected)

Details

Fennec nightly updates are broken again, it seems. It downloads but then fails to install. In the logcat I see a hash failure:

08-16 00:53:09.247 I/UpdateService(17945): completed update download!
08-16 00:53:09.247 I/UpdateService(17945): have update package at /storage/emulated/0/Download/fennec-43.0a1.en-US.android-arm.apk
08-16 00:53:09.257 I/UpdateService(17945): Verifying package: /storage/emulated/0/Download/fennec-43.0a1.en-US.android-arm.apk
08-16 00:53:11.059 W/PowerUI (  657): unknown intent: Intent { act=android.intent.action.ACTION_POWER_CONNECTED flg=0x8000010 }
08-16 00:53:11.069 I/ActivityManager(  530): Start proc com.google.android.gallery3d for broadcast com.google.android.gallery3d/com.google.android.picasasync.BatteryReceiver: pid=18015 uid=10020 gids={50020, 1006, 3003, 1015, 1028}
08-16 00:53:11.159 D/dalvikvm(18015): GC_CONCURRENT freed 412K, 5% free 8704K/9144K, paused 2ms+2ms, total 19ms
08-16 00:53:11.179 E/UpdateService(17945): Package hash does not match
08-16 00:53:11.179 E/UpdateService(17945): Not installing update, failed verification

The nightly I have now is 43.0a1/2015-08-13 and it won't update beyond that.
NI'ing/CC'ing people who worked on bug 1174581 the last time this happened.
Flags: needinfo?(mshal)
I think this is a dupe of bug 1194741. Looks like the last round of nightlies built correctly as far as I can tell, so we might just need to unlock updates on balrog.
Flags: needinfo?(mshal)
Yup, thanks.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1194741
You need to log in before you can comment on or make changes to this bug.