If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

lose messages in mail folders whose name contain square brackets

VERIFIED DUPLICATE of bug 94512

Status

MailNews Core
Filters
--
critical
VERIFIED DUPLICATE of bug 94512
16 years ago
9 years ago

People

(Reporter: Sven Sandberg, Assigned: Bienvenu)

Tracking

({dataloss})

Trunk
x86
Windows ME
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-GB; rv:0.9.4)
Gecko/20011128 Netscape6/6.2.1
BuildID:    6

I had two folders, [AL] and [AD], and some other folders which did not contain
square brackets. I had filters sorting some messages into these folders. First
time I started netscape's mail program, I downloaded my messages (about 500 to
1000 in each of the folders). Everything was fine. Next time I started the
program, most of my messages were gone. There were about 2-3 messages in the
folders, but I think I downloaded these in the same session, so all old messages
were gone. From now on my story is messy because I don't remember the exact
order in which things happened, but I maybe it contains some useful information
nevertheless. I tried to delete the mailboxes from the program and I also tried
to delete the .msf files for the mailboxes. At some point the program created
two new folders, with names which looked like 32 bit hexadecimal numbers. They
worked like "bookmarks" to [AL] and [AD], so any messages in [AL] and [AD] also
appeared in the new hexadecimal folders. Also, I couldn't delete the hexadecimal
folders (sometimes they reappeared when I restarted netscape, sometimes it said
something like "can't move folder because it already exists on the target"). At
all times, the sizes of the mail files on disk indicated that they really
contained all messages (so the mail program was merely hiding them from me).

The problem went away when I uninstalled, then reinstalled netscape, and did not
use square brackets in folder names.

Reproducible: Didn't try

You only asked for the number appearing in the title bar, which is 6 (preceded
by "Netscape"), but you probably also want to know the following (cut and pasted
from the two first lines of the page appearing when selecting "About Netscape 6"
in the Help menu of navigator).

Netscape 6.2.1
Mozilla/5.0 (Windows; U; Win 9x 4.90; en-GB; rv:0.9.4) Gecko/20011128
Netscape6/6.2.1
(Assignee)

Comment 1

16 years ago
You were using Netscape mail filters to filter the mail? Are you using POP3 or
IMAP? I can't really tell from you description.
Component: Mail Database → Filters

Updated

16 years ago
Keywords: dataloss

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 94512 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified dup...

from the bug report:

'The problem went away when I uninstalled, then reinstalled netscape, and did not
use square brackets in folder names.'

Status: RESOLVED → VERIFIED
Summary: loose messages in mail folders whose name contain square brackets → lose messages in mail folders whose name contain square brackets
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.