Ability to Assign Bug to More than one Owner

VERIFIED DUPLICATE of bug 50890

Status

()

Bugzilla
Creating/Changing Bugs
--
enhancement
VERIFIED DUPLICATE of bug 50890
16 years ago
5 years ago

People

(Reporter: Mark E. Stahl, Assigned: myk)

Tracking

Details

(Reporter)

Description

16 years ago
There are many bugs that come through our bug system that require the
coordination of several programmers.

Since there is exactly one assignee for each bug, there are often bugs that I
need to work on, but where I'm not the assignee.  Currently, the only way for me
to get onto the bug list (and to search for bugs that I'm interested in) is to
add my name to the CC field.

However, I am also involved in design issues throughout the product, so I need
to monitor many bugs that I will never work on directly.  Again, the only way to
watch these bugs is to add myself to the CC field.

Here's the problem.  When I want to search for all bugs in my "to-do" list, I
have to search either for all bugs I'm the assignee (which is incomplete) or
search for all bugs I"m CCed to (which is overkill).

It might be nice if there could be more than one assignee.  Or one could make a
primary assignee, and have any number of secondary assignees.

Until then, I guess I can use the status whiteboard as a work-around.

Comment 1

16 years ago
You could possibly set up a mailing list and make its address be the owner, or 
qa_contact for a component. Then all who are subscribed to the mailing list would 
see the email announcements.
(Reporter)

Comment 2

16 years ago
True, as a way of monitoring bugs that I don't want in my CC list.  But that
requires a lot of "external configuration" in order to get the effect I want,
and it doesn't easily address the CC issue. 

I feel the main shortcoming of the current system is the lack of standard way to
mark bugs that I want to WORK on (when I'm not the assignee) separtely from bugs
just want to WATCH, so that I can search for all my 'work' bugs without getting
my 'watch' bugs.  

*** This bug has been marked as a duplicate of 50890 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
QA Contact: matty → jake
Resolution: --- → DUPLICATE

Comment 4

16 years ago
V. Dupe
Status: RESOLVED → VERIFIED
QA Contact: jake → default-qa
You need to log in before you can comment on or make changes to this bug.