An option to completely disable Data Reporting

RESOLVED WORKSFORME

Status

Firefox Health Report
Client: Desktop
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Yaron, Unassigned)

Tracking

40 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150706172413

Steps to reproduce:

I've set the following prefs:

user_pref("datareporting.healthreport.service.enabled", false);
user_pref("datareporting.healthreport.uploadEnabled", false);
user_pref("datareporting.policy.dataSubmissionEnabled", false);
user_pref("toolkit.telemetry.unified", false);


Actual results:

Firefox 40.0.2 has created a new folder "datareporting" in my profile folder, and keeps adding new items to it.


Expected results:

Data Reporting should be completely disabled.
Is this a bug? Or am I missing a new pref?

I'd appreciate your help.
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86

Updated

2 years ago
Component: Untriaged → Client: Desktop
Product: Firefox → Firefox Health Report

Comment 1

2 years ago
Georg, can you have a look? This looks like a unified telemetry / fhr thing.
Flags: needinfo?(gfritzsche)
"datareporting.policy.dataSubmissionEnabled" is the kill-switch for uploads, so the actual reporting is off.
We still maintain state locally though.

What is your goal here, to disable reporting/uploading?
Flags: needinfo?(gfritzsche)
(Reporter)

Comment 3

2 years ago
Thank you Gijs and Georg,

I'd like to disable any reporting activity.

Please see:
http://forums.mozillazine.org/viewtopic.php?p=14289125#p14289125

Regards.
Having "datareporting.healthreport.uploadEnabled" & "toolkit.telemetry.enabled" set to false disables any upload/reporting on 40 release.
From Firefox 41 on, "datareporting.policy.dataSubmissionEnabled" is the master-kill-switch for any upload/reporting for FHR and Telemetry.
 
This documents all the prefs, but is subject to change:
https://gecko.readthedocs.org/en/latest/toolkit/components/telemetry/telemetry/preferences.html

Some local datareporting files can't be turned off anymore (like saving the client id), but that doesn't mean that its submitted.
The focus for Firefox is on having data upload be switchable, not the whole collection system.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

2 years ago
Hi Georg,

Thanks for the detailed explanation. I appreciate it.

What's the point of having the collection system working if submission is not allowed?
Why not have an option do disable the entire module?

Best regards.
The data that is available locally powers e.g. about:healthreport, without ever uploading data anywhere.
Thus the focus is not on completely disabling the collection system (although the prefs may generally allow it).

I hope that gives enough context, lets follow up on e.g. fhr-dev (the current main "measurements" team list, [0]) or IRC if needed.

0: https://mail.mozilla.org/listinfo/fhr-dev
(Reporter)

Comment 7

2 years ago
Thanks again Georg. I've sent a mail.

Gijs, I'd like to thank you again too.

Comment 8

2 years ago
(In reply to Georg Fritzsche [:gfritzsche] from comment #4)
> From Firefox 41 on, "datareporting.policy.dataSubmissionEnabled" is the
> master-kill-switch for any upload/reporting for FHR and Telemetry.
>  
> This documents all the prefs, but is subject to change:
> https://gecko.readthedocs.org/en/latest/toolkit/components/telemetry/
> telemetry/preferences.html

In case this documentation is more or less up-to-date: It also says that datareporting.policy.dataSubmissionEnabled disables showing the policy but this seems to be not the case with Firefox 41. Also about:healthreport shows the Data Sharing as ON if this preference is set to false and preferred over datareporting.healthreport.uploadEnabled.
You need to log in before you can comment on or make changes to this bug.