[gcc-4.8.4] Firefox/Thunderbird-38.1 ESR ucol_*.cpp warning: array subscript is above array bounds [-Warray-bounds]

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Ikonta, Unassigned)

Tracking

38 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0
Build ID: 20150720112201

Steps to reproduce:

During update to current ESR release (38.1.1) on my Gentoo GNU/Linux box (using gcc-4.8.4 compiller on amd64 system) I've got the following QA notices:


Actual results:

For Firefox:

 * QA Notice: Package triggers severe warnings which indicate that it
 *            may exhibit random runtime failures.
 * /var/tmp/portage/www-client/firefox-38.1.1/work/mozilla-esr38/intl/icu/source/i18n/ucol_bld.cpp:807:40: warning: array subscript is above array bounds [-Warray-bounds]
 * /var/tmp/portage/www-client/firefox-38.1.1/work/mozilla-esr38/intl/icu/source/i18n/ucol_wgt.cpp:267:57: warning: array subscript is below array bounds [-Warray-bounds]
 * /var/tmp/portage/www-client/firefox-38.1.1/work/mozilla-esr38/intl/icu/source/i18n/ucol_wgt.cpp:267:37: warning: array subscript is below array bounds [-Warray-bounds]
 * /var/tmp/portage/www-client/firefox-38.1.1/work/mozilla-esr38/intl/icu/source/i18n/ucol_wgt.cpp:267:57: warning: array subscript is below array bounds [-Warray-bounds]
 * /var/tmp/portage/www-client/firefox-38.1.1/work/mozilla-esr38/intl/icu/source/i18n/ucol_wgt.cpp:267:37: warning: array subscript is below array bounds [-Warray-bounds]

 * Please do not file a Gentoo bug and instead report the above QA
 * issues directly to the upstream developers of this software.
 * Homepage: http://www.mozilla.com/firefox

For Thunderbird:

 * QA Notice: Package triggers severe warnings which indicate that it
 *            may exhibit random runtime failures.
 * /var/tmp/portage/mail-client/thunderbird-38.1.0/work/comm-esr38/mozilla/intl/icu/source/i18n/ucol_bld.cpp:807:40: warning: array subscript is above array bounds [-Warray-bounds]
 * /var/tmp/portage/mail-client/thunderbird-38.1.0/work/comm-esr38/mozilla/intl/icu/source/i18n/ucol_wgt.cpp:267:57: warning: array subscript is below array bounds [-Warray-bounds]
 * /var/tmp/portage/mail-client/thunderbird-38.1.0/work/comm-esr38/mozilla/intl/icu/source/i18n/ucol_wgt.cpp:267:37: warning: array subscript is below array bounds [-Warray-bounds]
 * /var/tmp/portage/mail-client/thunderbird-38.1.0/work/comm-esr38/mozilla/intl/icu/source/i18n/ucol_wgt.cpp:267:57: warning: array subscript is below array bounds [-Warray-bounds]
 * /var/tmp/portage/mail-client/thunderbird-38.1.0/work/comm-esr38/mozilla/intl/icu/source/i18n/ucol_wgt.cpp:267:37: warning: array subscript is below array bounds [-Warray-bounds]

 * Please do not file a Gentoo bug and instead report the above QA
 * issues directly to the upstream developers of this software.
 * Homepage: http://www.mozilla.com/en-US/thunderbird/


Expected results:

Keeping in mind notice: «…warnings which indicate that it may exhibit random runtime failures» I would like to see sources corrected not to produce these warnings.
(Reporter)

Updated

3 years ago
Summary: [gcc-4.8.4] Firefox/Thunderbird-38.1.1 ESR ucol_*.cpp warning: array subscript is above array bounds [-Warray-bounds] → [gcc-4.8.4] Firefox/Thunderbird-38.1 ESR ucol_*.cpp warning: array subscript is above array bounds [-Warray-bounds]

Comment 1

3 years ago
Hi,
Do you still have this problem? If yes please give us the exact steps to try to reproduce the issue.
Flags: needinfo?(Ikonta)

Comment 2

3 years ago
Hi,
Marking this as Resolved: Incomplete due to the lack of response from the reporter.
Reporter, please feel free to reopen it if you are still having this issue on the latest Firefox version.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(Ikonta)
Resolution: --- → INCOMPLETE
(Reporter)

Comment 3

3 years ago
Excuse me for long response.
On next update this issue seemded to be fixed.
And it don't appear with recent compiler (gcc-4.9.3).
Resolution: INCOMPLETE → WORKSFORME
You need to log in before you can comment on or make changes to this bug.